summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-02-22 12:45:38 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-02-22 12:45:38 +0000
commit4fb2cd18c19821c7f8f7f5124ce5061d4405bf32 (patch)
tree23b2a00979d15b07b17f4c2e728657e68494fa03 /package
parenta7b262dc0af14caae7ec190412ba1d9327200252 (diff)
downloadmaster-31e0f0ae-4fb2cd18c19821c7f8f7f5124ce5061d4405bf32.tar.gz
master-31e0f0ae-4fb2cd18c19821c7f8f7f5124ce5061d4405bf32.tar.bz2
master-31e0f0ae-4fb2cd18c19821c7f8f7f5124ce5061d4405bf32.zip
firewall3: add support for shell script and iptables-restore style includes
SVN-Revision: 35744
Diffstat (limited to 'package')
-rw-r--r--package/network/config/firewall3/Makefile4
-rw-r--r--package/network/config/firewall3/files/firewall.hotplug4
2 files changed, 4 insertions, 4 deletions
diff --git a/package/network/config/firewall3/Makefile b/package/network/config/firewall3/Makefile
index 5282613d65..f4a9b18e28 100644
--- a/package/network/config/firewall3/Makefile
+++ b/package/network/config/firewall3/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=firewall3
-PKG_VERSION:=2013-02-21
+PKG_VERSION:=2013-02-22
PKG_RELEASE:=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/firewall3.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=fe3ecee341da8542aa25b962dcb8bcc628fcdd1e
+PKG_SOURCE_VERSION:=83ff4b94b044086d80b1e189e5601274bd5b4852
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
diff --git a/package/network/config/firewall3/files/firewall.hotplug b/package/network/config/firewall3/files/firewall.hotplug
index a173b130bf..dbb98cdcd2 100644
--- a/package/network/config/firewall3/files/firewall.hotplug
+++ b/package/network/config/firewall3/files/firewall.hotplug
@@ -4,5 +4,5 @@
fw3 -q network "$INTERFACE" >/dev/null || exit 0
-logger -t firewall "Restarting firewall due to ifup of $INTERFACE ($DEVICE)"
-fw3 -q restart
+logger -t firewall "Reloading firewall due to ifup of $INTERFACE ($DEVICE)"
+fw3 -q reload