summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2013-12-05 12:17:09 +0000
committerSteven Barth <cyrus@openwrt.org>2013-12-05 12:17:09 +0000
commit4bdd40c08ba4dd8ca9597cab29dbbb60c3de6f04 (patch)
tree9b320bafa8ca464761d6240a9df427fa02d6eec8 /package
parent95065c08b0d9e6a8631e40d442ee2f60e480218a (diff)
downloadmaster-31e0f0ae-4bdd40c08ba4dd8ca9597cab29dbbb60c3de6f04.tar.gz
master-31e0f0ae-4bdd40c08ba4dd8ca9597cab29dbbb60c3de6f04.tar.bz2
master-31e0f0ae-4bdd40c08ba4dd8ca9597cab29dbbb60c3de6f04.zip
odhcpd/6c: Add config menu for prefix class ext.
SVN-Revision: 38996
Diffstat (limited to 'package')
-rw-r--r--package/network/ipv6/odhcp6c/Makefile11
-rw-r--r--package/network/services/odhcpd/Makefile11
2 files changed, 22 insertions, 0 deletions
diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index 845dc579e9..bd794dc864 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -21,6 +21,10 @@ PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
+ifneq ($(CONFIG_PACKAGE_odhcp6c_ext_prefix_class),0)
+ CMAKE_OPTIONS += -DEXT_PREFIX_CLASS=$(CONFIG_PACKAGE_odhcp6c_ext_prefix_class)
+endif
+
define Package/odhcp6c
SECTION:=net
CATEGORY:=Network
@@ -28,6 +32,13 @@ define Package/odhcp6c
DEPENDS:=+kmod-ipv6
endef
+define Package/odhcp6c/config
+ config PACKAGE_odhcp6c_ext_prefix_class
+ int "Prefix Class Extension ID (0 = disabled)"
+ depends on PACKAGE_odhcp6c
+ default 0
+endef
+
define Package/odhcp6c/install
$(INSTALL_DIR) $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/odhcp6c $(1)/usr/sbin/
diff --git a/package/network/services/odhcpd/Makefile b/package/network/services/odhcpd/Makefile
index e660600fee..c4f76cbd62 100644
--- a/package/network/services/odhcpd/Makefile
+++ b/package/network/services/odhcpd/Makefile
@@ -22,6 +22,10 @@ PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
+ifneq ($(CONFIG_PACKAGE_odhcpd_ext_prefix_class),0)
+ CMAKE_OPTIONS += -DEXT_PREFIX_CLASS=$(CONFIG_PACKAGE_odhcpd_ext_prefix_class)
+endif
+
define Package/odhcpd
SECTION:=net
CATEGORY:=Network
@@ -29,6 +33,13 @@ define Package/odhcpd
DEPENDS:=+libubox +libuci +libubus
endef
+define Package/odhcpd/config
+ config PACKAGE_odhcpd_ext_prefix_class
+ int "Prefix Class Extension ID (0 = disabled)"
+ depends on PACKAGE_odhcpd
+ default 0
+endef
+
define Package/odhcpd/description
odhcpd is a daemon for serving and relaying IP management protocols to
configure clients and downstream routers. It tries to follow the RFC 6204