summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-03-28 02:35:45 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-03-28 02:35:45 +0000
commit4bc74807e48f823bdf743d19592d4321dfdb6481 (patch)
tree959c139aba0895ce98b64645a9c2a49a02cc7a56 /package
parent8779e971edeb8da04c4dc93f27fb657db3421e50 (diff)
downloadmaster-31e0f0ae-4bc74807e48f823bdf743d19592d4321dfdb6481.tar.gz
master-31e0f0ae-4bc74807e48f823bdf743d19592d4321dfdb6481.tar.bz2
master-31e0f0ae-4bc74807e48f823bdf743d19592d4321dfdb6481.zip
uhttpd: fix parameter parsing issue on avr32 and most likely ixp4xx
SVN-Revision: 20532
Diffstat (limited to 'package')
-rw-r--r--package/uhttpd/Makefile3
-rw-r--r--package/uhttpd/src/uhttpd.c2
2 files changed, 3 insertions, 2 deletions
diff --git a/package/uhttpd/Makefile b/package/uhttpd/Makefile
index 2b7714d30f..4bee17d234 100644
--- a/package/uhttpd/Makefile
+++ b/package/uhttpd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
@@ -56,6 +56,7 @@ endef
# hack to use CyASSL headers
TARGET_CFLAGS += -I$(firstword $(wildcard $(BUILD_DIR)/cyassl-*/include))
+TARGET_LDFLAGS += -lm
MAKE_VARS += FPIC="$(FPIC)"
define Build/Prepare
diff --git a/package/uhttpd/src/uhttpd.c b/package/uhttpd/src/uhttpd.c
index be13b536d7..c6a8b6c272 100644
--- a/package/uhttpd/src/uhttpd.c
+++ b/package/uhttpd/src/uhttpd.c
@@ -422,7 +422,7 @@ int main (int argc, char **argv)
int nofork = 0;
/* args */
- char opt;
+ int opt;
char bind[128];
char *port = NULL;