summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-04-19 15:42:16 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-04-19 15:42:16 +0000
commit489252ab43a413a13e483c50ea65ea5f84f3d75b (patch)
tree4a18f0983f2af572e9261a948903952582d129cf /package
parent14aa5dc5c11beb443b28d89ecce4624c8762b89f (diff)
downloadmaster-31e0f0ae-489252ab43a413a13e483c50ea65ea5f84f3d75b.tar.gz
master-31e0f0ae-489252ab43a413a13e483c50ea65ea5f84f3d75b.tar.bz2
master-31e0f0ae-489252ab43a413a13e483c50ea65ea5f84f3d75b.zip
add sata_sil24 module Signed-off-by: Erik Inge Bols? <knan-openwrt@anduin.net>
SVN-Revision: 15261
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/block.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/block.mk b/package/kernel/modules/block.mk
index 3c27813972..ce9596e8a8 100644
--- a/package/kernel/modules/block.mk
+++ b/package/kernel/modules/block.mk
@@ -35,6 +35,22 @@ endef
$(eval $(call KernelPackage,ata-ahci))
+define KernelPackage/ata-sil24
+ SUBMENU:=3D$(BLOCK_MENU)
+ TITLE:=3DSilicon Image 3124/3132 SATA support
+ DEPENDS:=3Dkmod-ata-core
+ KCONFIG:=3DCONFIG_SATA_SIL24
+ FILES:=3D$(LINUX_DIR)/drivers/ata/sata_sil24.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=3D$(call AutoLoad,41,sata_sil24)
+endef
+
+define KernelPackage/ata-sil24/description
+ Support for Silicon Image 3124/3132 Serial ATA controllers.
+endef
+
+$(eval $(call KernelPackage,ata-sil24))
+
+
define KernelPackage/ata-artop
SUBMENU:=$(BLOCK_MENU)
TITLE:=ARTOP 6210/6260 PATA support