summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-10-30 10:10:45 +0000
committerJohn Crispin <john@openwrt.org>2014-10-30 10:10:45 +0000
commit4654319964c3601d73285b1021a9f981e83f196d (patch)
treef923348ebdf38ea9b962258ce9d168dd1e1ca862 /package
parent0b19244498b86665c4f093b01b92a8ae0965c4f9 (diff)
downloadmaster-31e0f0ae-4654319964c3601d73285b1021a9f981e83f196d.tar.gz
master-31e0f0ae-4654319964c3601d73285b1021a9f981e83f196d.tar.bz2
master-31e0f0ae-4654319964c3601d73285b1021a9f981e83f196d.zip
procd: Allow boot messages to be sent to console
update to latest git HEAD, adds "log to console" Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 43118
Diffstat (limited to 'package')
-rw-r--r--package/system/procd/Makefile21
1 files changed, 19 insertions, 2 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 734b44467b..0065bee850 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=procd
-PKG_VERSION:=2014-10-14
+PKG_VERSION:=2014-10-30
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=b9a389c841db8433bb3b02158b1512cf577dbff7
+PKG_SOURCE_VERSION:=07c7864d49723b1264ee8bcd6861ea92f679ee98
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
@@ -43,6 +43,23 @@ define Package/procd-nand
TITLE:=OpenWrt sysupgrade nand helper
endef
+define Package/procd/config
+menu "Configuration"
+ depends on PACKAGE_procd
+
+config PROCD_SHOW_BOOT
+ bool
+ default n
+ prompt "Print the shutdown to the console as well as logging it to syslog"
+endmenu
+endef
+
+PKG_CONFIG_DEPENDS:= PROCD_SHOW_BOOT
+
+ifeq ($(CONFIG_PACKAGE_PROCD_SHOW_BOOT),y)
+ CMAKE_OPTIONS += -DSHOW_BOOT_ON_CONSOLE
+endif
+
define Package/procd/install
$(INSTALL_DIR) $(1)/sbin $(1)/etc $(1)/lib/functions