summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-04 01:25:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-04 01:25:54 +0000
commit424e15a610fb237e9cd4556ed3d6d5594c2c1ae6 (patch)
tree5b173fe60f7d25c162f8947a4a50e11a24de25aa /package
parentdf6477e24241450f8df0bce327b4790e5a9c3905 (diff)
downloadmaster-31e0f0ae-424e15a610fb237e9cd4556ed3d6d5594c2c1ae6.tar.gz
master-31e0f0ae-424e15a610fb237e9cd4556ed3d6d5594c2c1ae6.tar.bz2
master-31e0f0ae-424e15a610fb237e9cd4556ed3d6d5594c2c1ae6.zip
another madwifi update
SVN-Revision: 7866
Diffstat (limited to 'package')
-rw-r--r--package/madwifi/Makefile4
-rw-r--r--package/madwifi/patches/125-plug_memleak.patch13
2 files changed, 2 insertions, 15 deletions
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index 5f7e610c98..0ad852f871 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -10,14 +10,14 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=madwifi
-PKG_VERSION:=r2525-20070630
+PKG_VERSION:=r2537-20070704
PKG_BRANCH:=madwifi-ng
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_BRANCH)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://snapshots.madwifi.org/$(PKG_BRANCH)
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BRANCH)-$(PKG_VERSION)
-PKG_MD5SUM:=4e0d01bc448bb1ba070ad34d4d6e1454
+PKG_MD5SUM:=ae4856030e5ffb939370bcd459e260af
include $(INCLUDE_DIR)/package.mk
diff --git a/package/madwifi/patches/125-plug_memleak.patch b/package/madwifi/patches/125-plug_memleak.patch
deleted file mode 100644
index 429b851a75..0000000000
--- a/package/madwifi/patches/125-plug_memleak.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: madwifi-ng-r2525-20070630/net80211/ieee80211_input.c
-===================================================================
---- madwifi-ng-r2525-20070630.orig/net80211/ieee80211_input.c 2007-07-03 23:02:31.005981500 +0200
-+++ madwifi-ng-r2525-20070630/net80211/ieee80211_input.c 2007-07-03 23:02:31.926039000 +0200
-@@ -2873,7 +2873,7 @@
- ieee80211_add_scan(vap, &scan, wh, subtype, rssi, rtsf);
- return;
- }
-- if (scan.capinfo & IEEE80211_CAPINFO_IBSS) {
-+ if ((vap->iv_opmode == IEEE80211_M_IBSS) && (scan.capinfo & IEEE80211_CAPINFO_IBSS)) {
- if (!IEEE80211_ADDR_EQ(wh->i_addr2, ni->ni_macaddr)) {
- /* Create a new entry in the neighbor table. */
- ni = ieee80211_add_neighbor(vap, wh, &scan);