summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-09-30 16:06:20 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-09-30 16:06:20 +0000
commit414761eeb3fd70f6347d89b60ad3cbc0a5c5f265 (patch)
tree05d734edfa4a6a7c179f2af9b415401d11b01a0f /package
parenteec0d12a0d0e8e2ba1c8213098d2d96d7845cf0a (diff)
downloadmaster-31e0f0ae-414761eeb3fd70f6347d89b60ad3cbc0a5c5f265.tar.gz
master-31e0f0ae-414761eeb3fd70f6347d89b60ad3cbc0a5c5f265.tar.bz2
master-31e0f0ae-414761eeb3fd70f6347d89b60ad3cbc0a5c5f265.zip
ppp: add dns servers to uci state in the ip-up script
SVN-Revision: 17801
Diffstat (limited to 'package')
-rw-r--r--package/ppp/Makefile2
-rwxr-xr-xpackage/ppp/files/etc/ppp/ip-up3
2 files changed, 4 insertions, 1 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index 919e105bbb..893c84dfea 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ppp
PKG_VERSION:=2.4.4
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
diff --git a/package/ppp/files/etc/ppp/ip-up b/package/ppp/files/etc/ppp/ip-up
index 46c8d37700..ecdd00b1c4 100755
--- a/package/ppp/files/etc/ppp/ip-up
+++ b/package/ppp/files/etc/ppp/ip-up
@@ -13,6 +13,9 @@ export PPP_IFACE PPP_TTY PPP_SPEED PPP_LOCAL PPP_REMOTE PPP_IPPARAM
uci_set_state network "$PPP_IPPARAM" unit "$PPP_UNIT"
uci_set_state network "$PPP_IPPARAM" ipaddr "$PPP_LOCAL"
uci_set_state network "$PPP_IPPARAM" gateway "$PPP_REMOTE"
+
+ local dns="$DNS1${DNS2:+ $DNS2}"
+ [ -n "$dns" ] && uci_set_state network "$PPP_IPPARAM" dns "$dns"
}
[ -z "$PPP_IPPARAM" ] || env -i ACTION="ifup" INTERFACE="$PPP_IPPARAM" DEVICE="$PPP_IFACE" PROTO=ppp /sbin/hotplug-call "iface"