summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-12 16:26:55 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-12 16:26:55 +0000
commit408af1f6c7f4e2f0bf38739569a37362664812aa (patch)
tree64c44e1570df2605e65e7c4e455e57975b0d72e7 /package
parent06382c5b15e18d75cc27646fd942036c9f19ee5a (diff)
downloadmaster-31e0f0ae-408af1f6c7f4e2f0bf38739569a37362664812aa.tar.gz
master-31e0f0ae-408af1f6c7f4e2f0bf38739569a37362664812aa.tar.bz2
master-31e0f0ae-408af1f6c7f4e2f0bf38739569a37362664812aa.zip
kernel: add kirkwood thermal module
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38371
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 65f2975a2b..453bedfc20 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -824,3 +824,20 @@ define KernelPackage/thermal-imx/description
endef
$(eval $(call KernelPackage,thermal-imx))
+
+
+define KernelPackage/thermal-kirkwood
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Temperature sensor on Marvell Kirkwood SoCs
+ DEPENDS:=@TARGET_kirkwood +kmod-thermal
+ KCONFIG:=CONFIG_KIRKWOOD_THERMAL
+ FILES:=$(LINUX_DIR)/drivers/thermal/kirkwood_thermal.ko
+ AUTOLOAD:=$(call AutoProbe,kirkwood_thermal)
+endef
+
+define KernelPackage/thermal-kirkwood/description
+ Support for the Kirkwood thermal sensor driver into the Linux thermal
+ framework. Only kirkwood 88F6282 and 88F6283 have this sensor.
+endef
+
+$(eval $(call KernelPackage,thermal-kirkwood))