summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-29 21:58:57 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-01-29 21:58:57 +0000
commit3fda4c9866e60e91e8d5051b2f8a1be6e502b627 (patch)
tree2b4981b7ed1fad0952a3f2c17ec060c0ac1fb1a8 /package
parent65f81429b4f56c20f3c76b91ce7e3740740a1075 (diff)
downloadmaster-31e0f0ae-3fda4c9866e60e91e8d5051b2f8a1be6e502b627.tar.gz
master-31e0f0ae-3fda4c9866e60e91e8d5051b2f8a1be6e502b627.tar.bz2
master-31e0f0ae-3fda4c9866e60e91e8d5051b2f8a1be6e502b627.zip
linux: fix kmod-usbip* for >= 3.17
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 44204
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/usb.mk12
1 files changed, 9 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 2499af1007..ecbf18668d 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1359,7 +1359,9 @@ define KernelPackage/usbip
KCONFIG:= \
CONFIG_USBIP_CORE \
CONFIG_USBIP_DEBUG=n
- FILES:=$(LINUX_DIR)/drivers/staging/usbip/usbip-core.ko
+ FILES:= \
+ $(LINUX_DIR)/drivers/staging/usbip/usbip-core.ko@lt3.17 \
+ $(LINUX_DIR)/drivers/usb/usbip/usbip-core.ko@ge3.17
AUTOLOAD:=$(call AutoProbe,usbip-core)
$(call AddDepends/usb)
endef
@@ -1371,7 +1373,9 @@ define KernelPackage/usbip-client
TITLE := USB-over-IP client driver
DEPENDS := +kmod-usbip
KCONFIG := CONFIG_USBIP_VHCI_HCD
- FILES := $(LINUX_DIR)/drivers/staging/usbip/vhci-hcd.$(LINUX_KMOD_SUFFIX)
+ FILES := \
+ $(LINUX_DIR)/drivers/staging/usbip/vhci-hcd.ko@lt3.17 \
+ $(LINUX_DIR)/drivers/usb/usbip/vhci-hcd.ko@ge3.17
AUTOLOAD := $(call AutoProbe,vhci-hcd)
$(call AddDepends/usb)
endef
@@ -1384,7 +1388,9 @@ $(call KernelPackage/usbip/Default)
TITLE := USB-over-IP host driver
DEPENDS := +kmod-usbip
KCONFIG := CONFIG_USBIP_HOST
- FILES := $(LINUX_DIR)/drivers/staging/usbip/usbip-host.ko
+ FILES := \
+ $(LINUX_DIR)/drivers/staging/usbip/usbip-host.ko@lt3.17 \
+ $(LINUX_DIR)/drivers/usb/usbip/usbip-host.ko@ge3.17
AUTOLOAD := $(call AutoProbe,usbip-host)
$(call AddDepends/usb)
endef