summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAndy Boyett <agb@openwrt.org>2008-06-22 18:41:25 +0000
committerAndy Boyett <agb@openwrt.org>2008-06-22 18:41:25 +0000
commit3dbe2e1093254fe5dbca5894183a36ae6ab877ae (patch)
tree1eefbef3441f5afb19c076b0c41cffde85668ce8 /package
parent0ddeec5cd536c71508edfb2470b38f550c86ee48 (diff)
downloadmaster-31e0f0ae-3dbe2e1093254fe5dbca5894183a36ae6ab877ae.tar.gz
master-31e0f0ae-3dbe2e1093254fe5dbca5894183a36ae6ab877ae.tar.bz2
master-31e0f0ae-3dbe2e1093254fe5dbca5894183a36ae6ab877ae.zip
ebtables: Update to 2.0.8-2
SVN-Revision: 11556
Diffstat (limited to 'package')
-rw-r--r--package/ebtables/Makefile17
-rw-r--r--package/ebtables/patches/100-autoconf_h.patch13
2 files changed, 12 insertions, 18 deletions
diff --git a/package/ebtables/Makefile b/package/ebtables/Makefile
index 9f61c8713e..7914e128ee 100644
--- a/package/ebtables/Makefile
+++ b/package/ebtables/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ebtables
-PKG_VERSION:=2.0.8-rc2
-PKG_RELEASE:=2
+PKG_VERSION:=2.0.8-2
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/ebtables
-PKG_MD5SUM:=f07111fcc1966be669278433c35dcc28
+PKG_MD5SUM:=66bcbcb2dcf3b981ad4e86e1720e796e
PKG_BUILD_DIR:=$(BUILD_DIR)/ebtables-v$(PKG_VERSION)
@@ -27,6 +27,13 @@ define Package/ebtables
URL:=http://ebtables.sourceforge.net/
endef
+define Package/ebtables/description
+ The ebtables program is a filtering tool for a bridging firewall. The
+ filtering is focussed on the Link Layer Ethernet frame fields. Apart
+ from filtering, it also gives the ability to alter the Ethernet MAC
+ addresses and implement a brouter.
+endef
+
MAKE_FLAGS += \
CFLAGS="$(TARGET_CFLAGS)"
diff --git a/package/ebtables/patches/100-autoconf_h.patch b/package/ebtables/patches/100-autoconf_h.patch
deleted file mode 100644
index 9235993da3..0000000000
--- a/package/ebtables/patches/100-autoconf_h.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: ebtables-v2.0.8-rc2/include/linux/netfilter_bridge.h
-===================================================================
---- ebtables-v2.0.8-rc2.orig/include/linux/netfilter_bridge.h 2007-06-04 13:22:27.306704032 +0200
-+++ ebtables-v2.0.8-rc2/include/linux/netfilter_bridge.h 2007-06-04 13:22:27.372694000 +0200
-@@ -4,7 +4,7 @@
- /* bridge-specific defines for netfilter.
- */
-
--#include <linux/config.h>
-+#include <linux/autoconf.h>
- #include <linux/netfilter.h>
- #if defined(__KERNEL__) && defined(CONFIG_BRIDGE_NETFILTER)
- #include <asm/atomic.h>