summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-01-04 14:08:08 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-01-04 14:08:08 +0000
commit3b7882e7752f154ce6407c892e7b92015c5c3481 (patch)
tree3f2896acd82184b74d5ad75ebd45df75c29198b4 /package
parentff0c7a9ec9d64c82a449a6da5fb25eb5ce37054e (diff)
downloadmaster-31e0f0ae-3b7882e7752f154ce6407c892e7b92015c5c3481.tar.gz
master-31e0f0ae-3b7882e7752f154ce6407c892e7b92015c5c3481.tar.bz2
master-31e0f0ae-3b7882e7752f154ce6407c892e7b92015c5c3481.zip
iwinfo: don't use the txpower value from debugfs for now, it does not match the values reported via wext
SVN-Revision: 35007
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/iwinfo/Makefile2
-rw-r--r--package/network/utils/iwinfo/src/iwinfo_nl80211.c2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/network/utils/iwinfo/Makefile b/package/network/utils/iwinfo/Makefile
index 0bea4ec78f..479dcb5f5b 100644
--- a/package/network/utils/iwinfo/Makefile
+++ b/package/network/utils/iwinfo/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libiwinfo
-PKG_RELEASE:=37
+PKG_RELEASE:=38
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
PKG_CONFIG_DEPENDS := \
diff --git a/package/network/utils/iwinfo/src/iwinfo_nl80211.c b/package/network/utils/iwinfo/src/iwinfo_nl80211.c
index ae75e6d86c..819845ad1d 100644
--- a/package/network/utils/iwinfo/src/iwinfo_nl80211.c
+++ b/package/network/utils/iwinfo/src/iwinfo_nl80211.c
@@ -993,6 +993,7 @@ int nl80211_get_channel(const char *ifname, int *buf)
int nl80211_get_txpower(const char *ifname, int *buf)
{
+#if 0
char *res;
char path[PATH_MAX];
@@ -1002,6 +1003,7 @@ int nl80211_get_txpower(const char *ifname, int *buf)
if ((*buf = nl80211_readint(path)) > -1)
return 0;
+#endif
return wext_get_txpower(ifname, buf);
}