summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-08-07 09:36:55 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-08-07 09:36:55 +0000
commit34e22309efd0e9ccb207daf0e09d413d373936b8 (patch)
treebb4adb9582bb4e17d5ad6c461ac2fd3d926108c4 /package
parent46c7a003ca000f0151706d9f694de77568685452 (diff)
downloadmaster-31e0f0ae-34e22309efd0e9ccb207daf0e09d413d373936b8.tar.gz
master-31e0f0ae-34e22309efd0e9ccb207daf0e09d413d373936b8.tar.bz2
master-31e0f0ae-34e22309efd0e9ccb207daf0e09d413d373936b8.zip
libiptc and libxtables should install their libraries as symbolic links (#5313, #5639)
SVN-Revision: 17162
Diffstat (limited to 'package')
-rw-r--r--package/iptables/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 190b69477d..818e686d47 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=iptables
PKG_VERSION:=1.4.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_MD5SUM:=08cd9196881657ea0615d926334cb7e9
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -329,12 +329,12 @@ endef
define Package/libiptc/install
$(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libiptc.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libiptc.so* $(1)/usr/lib/
endef
define Package/libxtables/install
$(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/libxtables.so.* $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxtables.so* $(1)/usr/lib/
endef
define BuildPlugin