summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-05-03 21:19:56 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-05-03 21:19:56 +0000
commit32f3c920a282ddabe859d694838ce41ff9a4e0b9 (patch)
tree48463553174e53629573779da79fcc0ebd2e460a /package
parentae5435adc9997342989b3b9473298a630a196d2a (diff)
downloadmaster-31e0f0ae-32f3c920a282ddabe859d694838ce41ff9a4e0b9.tar.gz
master-31e0f0ae-32f3c920a282ddabe859d694838ce41ff9a4e0b9.tar.bz2
master-31e0f0ae-32f3c920a282ddabe859d694838ce41ff9a4e0b9.zip
kernel: add kmod-crypto-{wq,rng,iv} This patch adds kmod-crypto-wq, kmod-crypto-rng, and kmod-crypto-iv packages. These packages provide some missing kernel crypto modules which are required for IPSEC. The strongswan4, ipsec-tools, and possibly other IPSEC packages do not work properly without these modules.
NOTE: The KCONFIG associated with each of these modules gets selected whenever CRYPTO_MANAGER (kmod-crypto-manager) is selected so these modules are already being built. Signed-off-by: Lars Hjersted <lars@hjersted.com> SVN-Revision: 26812
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/crypto.mk32
1 files changed, 32 insertions, 0 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index b895224b2c..5aa954900d 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -76,6 +76,38 @@ define KernelPackage/crypto-manager
endef
$(eval $(call KernelPackage,crypto-manager))
+define KernelPackage/crypto-wq
+ TITLE:=CryptoAPI work queue handling
+ KCONFIG:=CONFIG_CRYPTO_WORKQUEUE
+ FILES:=$(LINUX_DIR)/crypto/crypto_wq.ko
+ AUTOLOAD:=$(call AutoLoad,09,crypto_wq)
+ $(call AddDepends/crypto)
+endef
+$(eval $(call KernelPackage,crypto-wq))
+
+define KernelPackage/crypto-rng
+ TITLE:=CryptoAPI random number generation
+ KCONFIG:=CONFIG_CRYPTO_RNG2
+ FILES:= \
+ $(LINUX_DIR)/crypto/rng.ko \
+ $(LINUX_DIR)/crypto/krng.ko
+ AUTOLOAD:=$(call AutoLoad,09,rng krng)
+ $(call AddDepends/crypto)
+endef
+$(eval $(call KernelPackage,crypto-rng))
+
+define KernelPackage/crypto-iv
+ TITLE:=CryptoAPI initialization vectors
+ DEPENDS:=+kmod-crypto-rng +kmod-crypto-wq
+ KCONFIG:= CONFIG_CRYPTO_BLKCIPHER2
+ FILES:= \
+ $(LINUX_DIR)/crypto/eseqiv.ko \
+ $(LINUX_DIR)/crypto/chainiv.ko
+ AUTOLOAD:=$(call AutoLoad,10,eseqiv chainiv)
+ $(call AddDepends/crypto)
+endef
+$(eval $(call KernelPackage,crypto-iv))
+
define KernelPackage/crypto-hw-padlock
TITLE:=VIA PadLock ACE with AES/SHA hw crypto module
DEPENDS:=+kmod-crypto-aes