summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-07-06 10:21:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-07-06 10:21:26 +0000
commit32549f52cb0f2a9316d894909b3fbef452d7b493 (patch)
tree0f5a843875b225b5c920ca2317ddca1c2e74b05f /package
parent6eea8046b33812463ae3c7e5066445a19b770ce6 (diff)
downloadmaster-31e0f0ae-32549f52cb0f2a9316d894909b3fbef452d7b493.tar.gz
master-31e0f0ae-32549f52cb0f2a9316d894909b3fbef452d7b493.tar.bz2
master-31e0f0ae-32549f52cb0f2a9316d894909b3fbef452d7b493.zip
ath10k: remove support for the obsolete STA firmware
Current firmware should work for station mode as well, and the older firmware will usually behave worse and become unsupported over time. Also, the MAC address handling on ar71xx is only implemented on one firmware version. Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 46197
Diffstat (limited to 'package')
-rw-r--r--package/kernel/mac80211/Makefile19
1 files changed, 0 insertions, 19 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index de82118b02..f7f7401728 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -621,19 +621,6 @@ Atheros IEEE 802.11ac family of chipsets. For now only
PCI is supported.
endef
-define KernelPackage/ath10k/config
- if PACKAGE_kmod-ath10k
-
- config ATH10K_STA_FW
- bool "Firmware optimized for STA operation"
- default n
- help
- Use the ath10k firmware optimized for wireless client instead
- of access point operation.
-
- endif
-endef
-
define KernelPackage/carl9170
$(call KernelPackage/mac80211/Default)
TITLE:=Driver for Atheros AR9170 USB sticks
@@ -1858,15 +1845,9 @@ define KernelPackage/ath10k/install
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/ath10k/QCA988X/hw2.0/board.bin \
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/
-ifeq ($(CONFIG_ATH10K_STA_FW),y)
- $(INSTALL_DATA) \
- $(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/main/firmware-2.bin_999.999.0.636 \
- $(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-2.bin
-else
$(INSTALL_DATA) \
$(PKG_BUILD_DIR)/$(PKG_ATH10K_LINUX_FIRMWARE_SUBDIR)/10.2.4/untested/firmware-5.bin_10.2.4.70-2 \
$(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
-endif
endef
define KernelPackage/mwl8k/install