summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-03-18 16:11:32 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-03-18 16:11:32 +0000
commit31876c193aaa8ddbe6c5758aee5754aee257fc44 (patch)
tree87fb9c06e3d6aacd00df5f6e5f0db88418ff346e /package
parent3ebdd3b330f31e3e98629e534a928af84136de1f (diff)
downloadmaster-31e0f0ae-31876c193aaa8ddbe6c5758aee5754aee257fc44.tar.gz
master-31e0f0ae-31876c193aaa8ddbe6c5758aee5754aee257fc44.tar.bz2
master-31e0f0ae-31876c193aaa8ddbe6c5758aee5754aee257fc44.zip
hostapd: fix build errors on supplicant-only builds
SVN-Revision: 36085
Diffstat (limited to 'package')
-rw-r--r--package/network/services/hostapd/Makefile4
-rw-r--r--package/network/services/hostapd/patches/700-ubus_support.patch6
2 files changed, 6 insertions, 4 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 0c44a8b08d..7024844d10 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -225,7 +225,9 @@ TARGET_CPPFLAGS := \
TARGET_CFLAGS += -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections
-TARGET_LDFLAGS += -lubox -lubus
+ifeq ($(findstring supplicant,$(BUILD_VARIANT)),)
+ TARGET_LDFLAGS += -lubox -lubus
+endif
ifdef CONFIG_PACKAGE_kmod-mac80211
TARGET_LDFLAGS += -lm -lnl-tiny
diff --git a/package/network/services/hostapd/patches/700-ubus_support.patch b/package/network/services/hostapd/patches/700-ubus_support.patch
index 92ca7b21ca..ad1a45bf38 100644
--- a/package/network/services/hostapd/patches/700-ubus_support.patch
+++ b/package/network/services/hostapd/patches/700-ubus_support.patch
@@ -422,14 +422,14 @@
+ const u8 *addr;
+};
+
++struct hostapd_iface;
++struct hostapd_data;
++
+#ifdef UBUS_SUPPORT
+
+#include <libubox/avl.h>
+#include <libubus.h>
+
-+struct hostapd_iface;
-+struct hostapd_data;
-+
+struct hostapd_ubus_iface {
+ struct ubus_object obj;
+};