summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-07-06 13:41:16 +0000
committerJohn Crispin <john@openwrt.org>2011-07-06 13:41:16 +0000
commit295da57040c6e80d464fc2fcc872222fdc4ca91d (patch)
treea0168ffdffddcded18081d9b5efd1b0ef5be8f08 /package
parenta832965eff3fd8d6540f2c3f12dbd969a55eb8ba (diff)
downloadmaster-31e0f0ae-295da57040c6e80d464fc2fcc872222fdc4ca91d.tar.gz
master-31e0f0ae-295da57040c6e80d464fc2fcc872222fdc4ca91d.tar.bz2
master-31e0f0ae-295da57040c6e80d464fc2fcc872222fdc4ca91d.zip
Lantiq TAPI driver also build for other platforms
thanks Matthias Buecher SVN-Revision: 27494
Diffstat (limited to 'package')
-rw-r--r--package/ltq-tapi/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/package/ltq-tapi/Makefile b/package/ltq-tapi/Makefile
index ecaac2eeb4..656ae15050 100644
--- a/package/ltq-tapi/Makefile
+++ b/package/ltq-tapi/Makefile
@@ -22,7 +22,7 @@ define KernelPackage/ltq-tapi
SUBMENU:=Voice over IP
TITLE:=Lantiq TAPI subsystem
URL:=http://www.lantiq.com/
- DEPENDS:=+kmod-ltq-ifxos @TARGET_lantiq
+ DEPENDS:=+kmod-ltq-ifxos @TARGET_lantiq_xway
FILES:=$(PKG_BUILD_DIR)/src/drv_tapi.ko
AUTOLOAD:=$(call AutoLoad,20,drv_tapi)
MAINTAINER:=John Crispin <blogic@openwrt.org>
@@ -60,10 +60,12 @@ define Build/Configure
$(call Build/Configure/Default)
endef
-define Build/InstallDev
+ifdef CONFIG_TARGET_lantiq
+ define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/drv_tapi
$(CP) --dereference $(PKG_BUILD_DIR)/include/* $(1)/usr/include/drv_tapi
(cd $(1)/usr/include/drv_tapi && ln -s . include && ln -s ../ifxos/ifx_types.h .)
-endef
+ endef
+endif
$(eval $(call KernelPackage,ltq-tapi))