summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-09-10 12:23:41 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-09-10 12:23:41 +0000
commit24e24b2d5194c5867ed15e1811b90a36836aa3c0 (patch)
treeed9b0cea581ee77919c8577399bb9465fcf1769d /package
parent77fe98d1342d957188c81675279e7202e2837f5c (diff)
downloadmaster-31e0f0ae-24e24b2d5194c5867ed15e1811b90a36836aa3c0.tar.gz
master-31e0f0ae-24e24b2d5194c5867ed15e1811b90a36836aa3c0.tar.bz2
master-31e0f0ae-24e24b2d5194c5867ed15e1811b90a36836aa3c0.zip
hostapd: introduce new default-off option "auth_cache" which controls PMKSA and Opportunistic Key Caching (#12129)
SVN-Revision: 33359
Diffstat (limited to 'package')
-rw-r--r--package/hostapd/Makefile2
-rw-r--r--package/hostapd/files/hostapd.sh5
2 files changed, 5 insertions, 2 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 122ee9b1a4..e438ef349e 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
PKG_VERSION:=20120428
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_REV:=1f0cc27eb98f7d1af9c64d0752238184cbdb9a24
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/hostapd/files/hostapd.sh b/package/hostapd/files/hostapd.sh
index 10062307e5..fc84ec50fc 100644
--- a/package/hostapd/files/hostapd.sh
+++ b/package/hostapd/files/hostapd.sh
@@ -84,6 +84,9 @@ hostapd_set_bss_options() {
config_get auth_secret "$vif" auth_secret
[ -z "$auth_secret" ] && config_get auth_secret "$vif" key
append "$var" "auth_server_shared_secret=$auth_secret" "$N"
+ config_get_bool auth_cache "$vif" auth_cache 0
+ [ "$auth_cache" -gt 0 ] || append "$var" "disable_pmksa_caching=1" "$N"
+ [ "$auth_cache" -gt 0 ] || append "$var" "okc=0" "$N"
config_get acct_server "$vif" acct_server
[ -n "$acct_server" ] && append "$var" "acct_server_addr=$acct_server" "$N"
config_get acct_port "$vif" acct_port
@@ -174,7 +177,7 @@ hostapd_set_bss_options() {
if [ "$wpa" -ge "2" ]
then
# RSN -> allow preauthentication
- config_get rsn_preauth "$vif" rsn_preauth
+ config_get_bool rsn_preauth "$vif" rsn_preauth "$auth_cache"
if [ -n "$bridge" -a "$rsn_preauth" = 1 ]
then
append "$var" "rsn_preauth=1" "$N"