summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-10-23 12:25:57 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-10-23 12:25:57 +0000
commit204bf6e5fef681cf4658edb9223ce1fa2a079ace (patch)
treec68d82b6134a4537e411824ff27d20ab2fc2202f /package
parent69df551be3c39d96f87d34855dd98a19fb650a93 (diff)
downloadmaster-31e0f0ae-204bf6e5fef681cf4658edb9223ce1fa2a079ace.tar.gz
master-31e0f0ae-204bf6e5fef681cf4658edb9223ce1fa2a079ace.tar.bz2
master-31e0f0ae-204bf6e5fef681cf4658edb9223ce1fa2a079ace.zip
firewall: prevent ip6tables -t nat rules (#10265)
SVN-Revision: 28535
Diffstat (limited to 'package')
-rw-r--r--package/firewall/Makefile2
-rw-r--r--package/firewall/files/lib/fw.sh3
2 files changed, 3 insertions, 2 deletions
diff --git a/package/firewall/Makefile b/package/firewall/Makefile
index 8ce0295ee5..637d0ecccb 100644
--- a/package/firewall/Makefile
+++ b/package/firewall/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=firewall
PKG_VERSION:=2
-PKG_RELEASE:=38
+PKG_RELEASE:=39
include $(INCLUDE_DIR)/package.mk
diff --git a/package/firewall/files/lib/fw.sh b/package/firewall/files/lib/fw.sh
index a8a7911494..7922d222f8 100644
--- a/package/firewall/files/lib/fw.sh
+++ b/package/firewall/files/lib/fw.sh
@@ -74,7 +74,8 @@ fw__exec() { # <action> <family> <table> <chain> <target> <position> { <rules> }
fw__rc $(($? & 1))
return
fi
- fw__rc 0
+ [ "$app" != ip6tables ] || [ "$tab" != nat ]
+ fw__rc $?
}
fw__err() {