summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-07-17 15:01:07 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-07-17 15:01:07 +0000
commit1ff200ead545f0ef27a938b329b32f1b926fcecb (patch)
tree2583dfde3826fde0448cce66d6b6ff0833e0cad3 /package
parent3994a2d1f9ce0913e08e83ca5aa87f3851d58ec6 (diff)
downloadmaster-31e0f0ae-1ff200ead545f0ef27a938b329b32f1b926fcecb.tar.gz
master-31e0f0ae-1ff200ead545f0ef27a938b329b32f1b926fcecb.tar.bz2
master-31e0f0ae-1ff200ead545f0ef27a938b329b32f1b926fcecb.zip
iptables: fix redundant binaries in iptables-utils & ip6tables-utils (#9691)
SVN-Revision: 27646
Diffstat (limited to 'package')
-rw-r--r--package/iptables/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 581c0fcdc4..b1ae19db17 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=iptables
PKG_VERSION:=1.4.10
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_MD5SUM:=f382fe693f0b59d87bd47bea65eca198
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -380,7 +380,9 @@ endef
define Package/iptables-utils/install
$(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/iptables-{save,restore} $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/iptables-multi $(1)/usr/sbin/
+ $(LN) iptables-multi $(1)/usr/sbin/iptables-save
+ $(LN) iptables-multi $(1)/usr/sbin/iptables-restore
endef
define Package/ip6tables/install
@@ -394,7 +396,9 @@ endef
define Package/ip6tables-utils/install
$(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ip6tables-{save,restore} $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ip6tables-multi $(1)/usr/sbin/
+ $(LN) ip6tables-multi $(1)/usr/sbin/ip6tables-save
+ $(LN) ip6tables-multi $(1)/usr/sbin/ip6tables-restore
endef
define Package/libiptc/install