summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-22 12:02:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-22 12:02:11 +0000
commit19e2d1ed35714b531a8b201b01adda471061b322 (patch)
tree4a72928ccfc3436429e7e06fcfb8441295953599 /package
parentc28fb1f4fc7f69a1c7385f75011ad4cb76171ace (diff)
downloadmaster-31e0f0ae-19e2d1ed35714b531a8b201b01adda471061b322.tar.gz
master-31e0f0ae-19e2d1ed35714b531a8b201b01adda471061b322.tar.bz2
master-31e0f0ae-19e2d1ed35714b531a8b201b01adda471061b322.zip
kernel: Add kernel module for Freescale SNVS RTC on chip module
Signed-off-by: Petr Štetiar <ynezz@true.cz> SVN-Revision: 48454
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index b244fbe538..528d32f0b7 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -666,6 +666,22 @@ endef
$(eval $(call KernelPackage,rtc-pt7c4338))
+define KernelPackage/rtc-snvs
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Freescale SNVS RTC support
+ DEPENDS:=@TARGET_imx6 @RTC_SUPPORT
+ KCONFIG:=CONFIG_RTC_DRV_SNVS \
+ CONFIG_RTC_CLASS=y
+ FILES:=$(LINUX_DIR)/drivers/rtc/rtc-snvs.ko
+ AUTOLOAD:=$(call AutoLoad,50,rtc-snvs,1)
+endef
+
+define KernelPackage/rtc-snvs/description
+ Kernel module for Freescale SNVS RTC on chip module
+endef
+
+$(eval $(call KernelPackage,rtc-snvs))
+
define KernelPackage/mtdtests
SUBMENU:=$(OTHER_MENU)