summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-21 15:37:38 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-21 15:37:38 +0000
commit16ea0369e9751bae9a0ac89ce2645701fcb83a99 (patch)
treeb882e2f34c40354bf7a609cc934b33991467748c /package
parentf82dc2e37dcfa9f763b932605687b7c19c7cb7ad (diff)
downloadmaster-31e0f0ae-16ea0369e9751bae9a0ac89ce2645701fcb83a99.tar.gz
master-31e0f0ae-16ea0369e9751bae9a0ac89ce2645701fcb83a99.tar.bz2
master-31e0f0ae-16ea0369e9751bae9a0ac89ce2645701fcb83a99.zip
kernel: make backlight support depend on display support
Mark backlight core package as hidden Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48437
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/video.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index 6925e80e1c..81e7e42b73 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -18,6 +18,8 @@ V4L2_USB_DIR=usb
define KernelPackage/backlight
SUBMENU:=$(VIDEO_MENU)
TITLE:=Backlight support
+ DEPENDS:=@DISPLAY_SUPPORT
+ HIDDEN:=1
KCONFIG:=CONFIG_BACKLIGHT_CLASS_DEVICE=m \
CONFIG_BACKLIGHT_LCD_SUPPORT=y \
CONFIG_LCD_CLASS_DEVICE=n \
@@ -39,7 +41,7 @@ $(eval $(call KernelPackage,backlight))
define KernelPackage/backlight-pwm
SUBMENU:=$(VIDEO_MENU)
TITLE:=PWM Backlight support
- DEPENDS:=+kmod-pwm kmod-backlight
+ DEPENDS:=+kmod-pwm +kmod-backlight
KCONFIG:=CONFIG_BACKLIGHT_PWM=m
FILES:=$(LINUX_DIR)/drivers/video/backlight/pwm_bl.ko
AUTOLOAD:=$(call AutoProbe,video pwm_bl)