summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2013-07-14 14:23:04 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2013-07-14 14:23:04 +0000
commit13f3c9dbe54dc05d8f23bfcf2f3d846a9dcf8aaf (patch)
treed435bf79af6caba06f421fc34a35214578e786d5 /package
parent71230b33c11548da605721d5f3a3a93501689986 (diff)
downloadmaster-31e0f0ae-13f3c9dbe54dc05d8f23bfcf2f3d846a9dcf8aaf.tar.gz
master-31e0f0ae-13f3c9dbe54dc05d8f23bfcf2f3d846a9dcf8aaf.tar.bz2
master-31e0f0ae-13f3c9dbe54dc05d8f23bfcf2f3d846a9dcf8aaf.zip
mac80211: b43: load b43 on core rev 17 and 18.
This is now controlled by a module parameter and the default configuration depends on brcmsmac being installed. This patch causes b43 to take core rev 17 and 18 always by default. SVN-Revision: 37307
Diffstat (limited to 'package')
-rw-r--r--package/kernel/mac80211/Makefile2
-rw-r--r--package/kernel/mac80211/patches/847-b43-always-take-overlapping-devs.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 2f7fbbe877..e4fa9252f1 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1221,7 +1221,7 @@ endif
config-$(call config_package,carl9170) += CARL9170
config-$(call config_package,b43) += B43
-config-y += B43_SSB B43_BCMA B43_BCMA_EXTRA B43_PHY_LP
+config-y += B43_SSB B43_BCMA B43_PHY_LP
config-$(CONFIG_PACKAGE_B43_PHY_N) += B43_PHY_N
config-$(CONFIG_PACKAGE_B43_PHY_HT) += B43_PHY_HT
config-$(CONFIG_PACKAGE_B43_PIO) += B43_PIO
diff --git a/package/kernel/mac80211/patches/847-b43-always-take-overlapping-devs.patch b/package/kernel/mac80211/patches/847-b43-always-take-overlapping-devs.patch
new file mode 100644
index 0000000000..9d1d419460
--- /dev/null
+++ b/package/kernel/mac80211/patches/847-b43-always-take-overlapping-devs.patch
@@ -0,0 +1,11 @@
+--- a/drivers/net/wireless/b43/main.c
++++ b/drivers/net/wireless/b43/main.c
+@@ -118,7 +118,7 @@ static int b43_modparam_pio = 0;
+ module_param_named(pio, b43_modparam_pio, int, 0644);
+ MODULE_PARM_DESC(pio, "Use PIO accesses by default: 0=DMA, 1=PIO");
+
+-static int modparam_allhwsupport = !IS_ENABLED(CPTCFG_BRCMSMAC);
++static int modparam_allhwsupport = 1;
+ module_param_named(allhwsupport, modparam_allhwsupport, int, 0444);
+ MODULE_PARM_DESC(allhwsupport, "Enable support for all hardware (even it if overlaps with the brcmsmac driver)");
+