summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-21 21:47:34 +0000
committerJohn Crispin <john@openwrt.org>2015-03-21 21:47:34 +0000
commit1312cd9263595f48a0e2f8826e4dbb5382da4371 (patch)
treec2c3891ce499c6ca975ac097fc0740bb224fe5f5 /package
parent35c52bc261e06b3b24ad5d6a3c8316fb0bf555b0 (diff)
downloadmaster-31e0f0ae-1312cd9263595f48a0e2f8826e4dbb5382da4371.tar.gz
master-31e0f0ae-1312cd9263595f48a0e2f8826e4dbb5382da4371.tar.bz2
master-31e0f0ae-1312cd9263595f48a0e2f8826e4dbb5382da4371.zip
lldpd: add Build/InstallDev rule
For using liblldpctl to talk to lldpd (via unix sockets). Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com> SVN-Revision: 44924
Diffstat (limited to 'package')
-rw-r--r--package/network/services/lldpd/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/network/services/lldpd/Makefile b/package/network/services/lldpd/Makefile
index f038a340ac..ff367f1c3e 100644
--- a/package/network/services/lldpd/Makefile
+++ b/package/network/services/lldpd/Makefile
@@ -49,6 +49,14 @@ define Package/lldpd/description
Link-Layer notifications to adjacent network devices.
endef
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblldpctl.so* $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/lldpctl.h $(1)/usr/include/lldpctl.h
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/lldp-const.h $(1)/usr/include/lldp-const.h
+endef
+
define Package/lldpd/install
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_DIR) $(1)/etc/lldpd.d