summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-12-15 01:59:29 +0000
committerJohn Crispin <john@openwrt.org>2012-12-15 01:59:29 +0000
commit12cfa4037559caacfb5d59fed0c232f64ed58890 (patch)
tree149db7206cff92b4e60aad51ba6c81c2ac0b0b3a /package
parent45834694137356384cd86373b78ce22721b54ace (diff)
downloadmaster-31e0f0ae-12cfa4037559caacfb5d59fed0c232f64ed58890.tar.gz
master-31e0f0ae-12cfa4037559caacfb5d59fed0c232f64ed58890.tar.bz2
master-31e0f0ae-12cfa4037559caacfb5d59fed0c232f64ed58890.zip
add crypto-pcompress
SVN-Revision: 34685
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/crypto.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index 383f9f318c..d8242952b9 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -60,6 +60,17 @@ define KernelPackage/crypto-manager
endef
$(eval $(call KernelPackage,crypto-manager))
+define KernelPackage/crypto-pcompress
+ TITLE:=CryptoAPI Partial (de)compression operations
+ KCONFIG:= \
+ CONFIG_CRYPTO_PCOMP=y \
+ CONFIG_CRYPTO_PCOMP2
+ FILES:=$(LINUX_DIR)/crypto/pcompress.ko
+ AUTOLOAD:=$(call AutoLoad,09,pcompress)
+ $(call AddDepends/crypto)
+endef
+$(eval $(call KernelPackage,crypto-pcompress))
+
define KernelPackage/crypto-user
TITLE:=CryptoAPI userspace interface
DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager