summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-08-07 16:08:08 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-08-07 16:08:08 +0000
commit105c0d3fa407458c7e79a9d4af2509aa931093ad (patch)
tree5bb215c52fdbdc638535c1fe67ffc236920f4674 /package
parent143ef2c8ff1b5b9c6eeb81b492bcecad8cab15ad (diff)
downloadmaster-31e0f0ae-105c0d3fa407458c7e79a9d4af2509aa931093ad.tar.gz
master-31e0f0ae-105c0d3fa407458c7e79a9d4af2509aa931093ad.tar.bz2
master-31e0f0ae-105c0d3fa407458c7e79a9d4af2509aa931093ad.zip
w1-gpio-custom: set enable_external_pullup to null (#8952)
SVN-Revision: 33034
Diffstat (limited to 'package')
-rw-r--r--package/w1-gpio-custom/Makefile4
-rw-r--r--package/w1-gpio-custom/src/w1-gpio-custom.c1
2 files changed, 3 insertions, 2 deletions
diff --git a/package/w1-gpio-custom/Makefile b/package/w1-gpio-custom/Makefile
index c1441e9caa..bf50d1a50f 100644
--- a/package/w1-gpio-custom/Makefile
+++ b/package/w1-gpio-custom/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=w1-gpio-custom
-PKG_RELEASE:=2
+PKG_RELEASE:=3
include $(INCLUDE_DIR)/package.mk
diff --git a/package/w1-gpio-custom/src/w1-gpio-custom.c b/package/w1-gpio-custom/src/w1-gpio-custom.c
index 8f739d49fd..96cfcabc61 100644
--- a/package/w1-gpio-custom/src/w1-gpio-custom.c
+++ b/package/w1-gpio-custom/src/w1-gpio-custom.c
@@ -112,6 +112,7 @@ static int __init w1_gpio_custom_add_one(unsigned int id, unsigned int *params)
pdata.pin = params[BUS_PARAM_PIN];
pdata.is_open_drain = params[BUS_PARAM_OD] ? 1:0;
+ pdata.enable_external_pullup = NULL;
err = platform_device_add_data(pdev, &pdata, sizeof(pdata));
if (err)