summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-10-29 22:11:57 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-10-29 22:11:57 +0000
commit0e3de8eff7bd1519d3aa750c6f2072f0fe82f041 (patch)
treecef27b3aafafffe7377870b737849f0cecd91436 /package
parent2b81aaa9eef31f9cb7fc16cd778251cca563a059 (diff)
downloadmaster-31e0f0ae-0e3de8eff7bd1519d3aa750c6f2072f0fe82f041.tar.gz
master-31e0f0ae-0e3de8eff7bd1519d3aa750c6f2072f0fe82f041.tar.bz2
master-31e0f0ae-0e3de8eff7bd1519d3aa750c6f2072f0fe82f041.zip
iwinfo: properly initialize memory of global nl80211_state, fixes random libnl-tiny assertions when using nl80211_probe() on not supported devices
SVN-Revision: 34003
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/iwinfo/Makefile2
-rw-r--r--package/network/utils/iwinfo/src/iwinfo_nl80211.c2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/network/utils/iwinfo/Makefile b/package/network/utils/iwinfo/Makefile
index f05fe4a786..bbef2bdc85 100644
--- a/package/network/utils/iwinfo/Makefile
+++ b/package/network/utils/iwinfo/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libiwinfo
-PKG_RELEASE:=35
+PKG_RELEASE:=36
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
PKG_CONFIG_DEPENDS := \
diff --git a/package/network/utils/iwinfo/src/iwinfo_nl80211.c b/package/network/utils/iwinfo/src/iwinfo_nl80211.c
index 304a18b3ec..763ed61c97 100644
--- a/package/network/utils/iwinfo/src/iwinfo_nl80211.c
+++ b/package/network/utils/iwinfo/src/iwinfo_nl80211.c
@@ -41,6 +41,8 @@ static int nl80211_init(void)
goto err;
}
+ memset(nls, 0, sizeof(*nls));
+
nls->nl_sock = nl_socket_alloc();
if (!nls->nl_sock) {
err = -ENOMEM;