summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-17 02:04:38 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-17 02:04:38 +0000
commit0d56d48d9aeecdbaaf30f3a4f8deb685f408c102 (patch)
treed2510e87f4c42a814557ac8eeaa9b6f46e315090 /package
parentf6197eabdafd2b45fc004741341fb342206178ee (diff)
downloadmaster-31e0f0ae-0d56d48d9aeecdbaaf30f3a4f8deb685f408c102.tar.gz
master-31e0f0ae-0d56d48d9aeecdbaaf30f3a4f8deb685f408c102.tar.bz2
master-31e0f0ae-0d56d48d9aeecdbaaf30f3a4f8deb685f408c102.zip
disable package that can't build on atheros target (no pci/usb)
SVN-Revision: 8823
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk5
-rw-r--r--package/rt2x00/Makefile3
2 files changed, 6 insertions, 2 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 8644d89ce2..9b5bc6d467 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -92,9 +92,11 @@ endef
$(eval $(call KernelPackage,lp))
+# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
define KernelPackage/soundcore
SUBMENU:=$(OTHER_MENU)
TITLE:=Sound support
+ DEPENDS:=@PCI_SUPPORT||USB_SUPPORT @!TARGET_atheros
KCONFIG:= \
CONFIG_SOUND \
CONFIG_SND \
@@ -238,10 +240,11 @@ endef
$(eval $(call KernelPackage,pcmcia-serial))
+# XXX: remove @!TARGET_* later when we have USB support properly detected on all targets
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT
+ DEPENDS:=@USB_SUPPORT @!TARGET_atheros
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \
diff --git a/package/rt2x00/Makefile b/package/rt2x00/Makefile
index a6c7e5c86b..71cd418be8 100644
--- a/package/rt2x00/Makefile
+++ b/package/rt2x00/Makefile
@@ -25,10 +25,11 @@ ifeq ($(DUMP),)
include $(LINUX_DIR)/.config
endif
+# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
define KernelPackage/rt2x00/Default
SUBMENU:=Wireless Drivers
TITLE:=Ralink Drivers for RT2x00 cards
- DEPENDS:=@LINUX_2_6
+ DEPENDS:=@LINUX_2_6 @!TARGET_atheros
KCONFIG:=CONFIG_MAC80211
endef