summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2008-06-11 19:59:16 +0000
committerJohn Crispin <john@openwrt.org>2008-06-11 19:59:16 +0000
commit0bf765b362eab76837418f087be074aba4ee12ab (patch)
tree7d382f284151e430ea066420cf46218af15c88e6 /package
parentab504da309f1282bea2bf76b23c2fa8173b17ae3 (diff)
downloadmaster-31e0f0ae-0bf765b362eab76837418f087be074aba4ee12ab.tar.gz
master-31e0f0ae-0bf765b362eab76837418f087be074aba4ee12ab.tar.bz2
master-31e0f0ae-0bf765b362eab76837418f087be074aba4ee12ab.zip
system now knows which timezone it is in
SVN-Revision: 11445
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile2
-rw-r--r--package/base-files/files/etc/config/system1
-rwxr-xr-xpackage/base-files/files/etc/init.d/boot4
3 files changed, 6 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index b80fee3ff7..bec33c8e05 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -161,7 +161,7 @@ define Package/base-files$(TARGET)/install
rm -f $(1)/var
ln -sf /tmp $(1)/var
mkdir -p $(1)/etc
- ln -sf /tmp/resolv.conf /tmp/fstab $(1)/etc/
+ ln -sf /tmp/resolv.conf /tmp/fstab /tmp/TZ $(1)/etc/
$(call Package/base-files/install-target,$(1))
for conffile in $(1)/etc/config/*; do \
if [ -f "$$$$conffile" ]; then \
diff --git a/package/base-files/files/etc/config/system b/package/base-files/files/etc/config/system
index 204a73a986..b0726b7b7b 100644
--- a/package/base-files/files/etc/config/system
+++ b/package/base-files/files/etc/config/system
@@ -1,2 +1,3 @@
config system
option hostname OpenWrt
+ option timezone UTC
diff --git a/package/base-files/files/etc/init.d/boot b/package/base-files/files/etc/init.d/boot
index df2afd6b8e..57c034eb48 100755
--- a/package/base-files/files/etc/init.d/boot
+++ b/package/base-files/files/etc/init.d/boot
@@ -12,6 +12,10 @@ system_config() {
config_get conloglevel "$cfg" conloglevel
[ -n "$conloglevel" ] && dmesg -n "$conloglevel"
+
+ config_get timezone "$cfg" timezone
+ [ -z "$timezone" ] && timezone=UTC
+ echo "$timezone" > /tmp/TZ
config_get log_ip "$cfg" log_ip
config_get log_size "$cfg" log_size