summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-02-14 19:07:13 +0000
committerJohn Crispin <john@openwrt.org>2012-02-14 19:07:13 +0000
commit07fb8159448a46a39921e64ca8611802f9213431 (patch)
treef76b5cb702e394c7cd18d106cc5b8c858b33567e /package
parent1a71f07d00f34acdc128dfd86401ba34931f749c (diff)
downloadmaster-31e0f0ae-07fb8159448a46a39921e64ca8611802f9213431.tar.gz
master-31e0f0ae-07fb8159448a46a39921e64ca8611802f9213431.tar.bz2
master-31e0f0ae-07fb8159448a46a39921e64ca8611802f9213431.zip
Add kernel module package for SLIP
This patch adds support for a kernel module package for SLIP. We needed it forusing tunslip6 from Contiki OS for 6LoWPAN communications. Signed-off-by: Markus Becker <mab@comnets.uni-bremen.de> SVN-Revision: 30538
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/netsupport.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index 93607302a2..bac681b75c 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -829,3 +829,28 @@ endef
$(eval $(call KernelPackage,netem))
+define KernelPackage/slip
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=SLIP modules
+ KCONFIG:= \
+ CONFIG_SLIP \
+ CONFIG_SLIP_COMPRESSED=y \
+ CONFIG_SLIP_SMART=y \
+ CONFIG_SLIP_MODE_SLIP6=y
+
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.2)),1)
+ FILES:= \
+ $(LINUX_DIR)/drivers/net/slip/slip.ko
+ else
+ FILES:= \
+ $(LINUX_DIR)/drivers/net/slip.ko
+ endif
+ AUTOLOAD:=$(call AutoLoad,30,slip)
+endef
+
+define KernelPackage/slip/description
+ Kernel modules for SLIP support
+endef
+
+$(eval $(call KernelPackage,slip))
+