summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2011-09-26 09:00:11 +0000
committerJohn Crispin <john@openwrt.org>2011-09-26 09:00:11 +0000
commit07986230f1b5ff482a46242da6eefd1055521f7b (patch)
tree852ba5112d0c38c8b7d412723d9a0d70c5135d38 /package
parentbfbbe5893f92cd572c48c4d37fbd975f148093d6 (diff)
downloadmaster-31e0f0ae-07986230f1b5ff482a46242da6eefd1055521f7b.tar.gz
master-31e0f0ae-07986230f1b5ff482a46242da6eefd1055521f7b.tar.bz2
master-31e0f0ae-07986230f1b5ff482a46242da6eefd1055521f7b.zip
* fixes brnboot image generation
SVN-Revision: 28307
Diffstat (limited to 'package')
-rw-r--r--package/uboot-lantiq/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/uboot-lantiq/Makefile b/package/uboot-lantiq/Makefile
index 015efcfe60..44a0eec8aa 100644
--- a/package/uboot-lantiq/Makefile
+++ b/package/uboot-lantiq/Makefile
@@ -119,15 +119,15 @@ endef
define Package/uboot-lantiq-$(BUILD_VARIANT)/install
mkdir -p $(1)
-ifneq ($(findstring ramboot,$(BUILD_VARIANT)),)
+ifneq ($(findstring flash,$(BUILD_VARIANT)),)
dd \
- if=$(PKG_BUILD_DIR)/$(BUILD_VARIANT)/u-boot.bin \
- of=$(1)/u-boot.bin \
+ if=$(PKG_BUILD_DIR)/$(BUILD_VARIANT)/u-boot-bootstrap.bin \
+ of=$(1)/u-boot-bootstrap.bin \
bs=64k conv=sync
else
dd \
- if=$(PKG_BUILD_DIR)/$(BUILD_VARIANT)/u-boot-bootstrap.bin \
- of=$(1)/u-boot-bootstrap.bin \
+ if=$(PKG_BUILD_DIR)/$(BUILD_VARIANT)/u-boot.bin \
+ of=$(1)/u-boot.bin \
bs=64k conv=sync
endif
ifneq ($(findstring ramboot,$(BUILD_VARIANT)),)