summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2011-04-19 21:40:29 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2011-04-19 21:40:29 +0000
commit0429ec0c1197b917f593a10bf303b69c9763d431 (patch)
tree5b7431928b044ee68ab6926cfd05c949f5d44c76 /package
parentcda9981625c8705d6a4af6c88658d26b393c2f57 (diff)
downloadmaster-31e0f0ae-0429ec0c1197b917f593a10bf303b69c9763d431.tar.gz
master-31e0f0ae-0429ec0c1197b917f593a10bf303b69c9763d431.tar.bz2
master-31e0f0ae-0429ec0c1197b917f593a10bf303b69c9763d431.zip
mac80211: b43: Expose debug option
Allow enabling debug output and debugfs for B43. Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com> SVN-Revision: 26734
Diffstat (limited to 'package')
-rw-r--r--package/mac80211/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 4de6b12210..330876f13b 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -33,6 +33,7 @@ PKG_CONFIG_DEPENDS:= \
$(patsubst %,CONFIG_PACKAGE_kmod-%,$(PKG_DRIVERS)) \
CONFIG_PACKAGE_MAC80211_DEBUGFS \
CONFIG_PACKAGE_ATH_DEBUG \
+ CONFIG_PACKAGE_B43_DEBUG \
CONFIG_ATH_USER_REGD \
CARL9170_FW_VERSION:=1.9.2
@@ -1108,6 +1109,15 @@ define KernelPackage/b43/config
Example (keep files for G-PHY and N-PHY):
G,N
+ config PACKAGE_B43_DEBUG
+ bool "Enable debug output and debugfs for b43"
+ default n
+ help
+ Enable additional debug output and runtime sanity checks for b43
+ and enables the debugfs interface.
+
+ If unsure, say N.
+
endmenu
endef
@@ -1168,6 +1178,7 @@ BUILDFLAGS:= \
-D__CONFIG_MAC80211_RC_DEFAULT=minstrel \
-DCONFIG_MAC80211_RC_MINSTREL_HT \
$(if $(CONFIG_ATH_USER_REGD),-DATH_USER_REGD=1) \
+ $(if $(CONFIG_PACKAGE_B43_DEBUG),-DCONFIG_B43_DEBUG) \
$(if $(CONFIG_PACKAGE_RT2X00_LIB_DEBUGFS),-DCONFIG_RT2X00_LIB_DEBUGFS) \
$(if $(CONFIG_PACKAGE_RT2X00_DEBUG),-DCONFIG_RT2X00_DEBUG) \
$(if $(NEED_RT2X00_LIB_HT),-DCONFIG_RT2X00_LIB_HT) \
@@ -1199,6 +1210,7 @@ MAKE_OPTS:= \
CONFIG_B43LEGACY_HWRNG=$(if $(CONFIG_HW_RANDOM),y) \
CONFIG_B43=$(if $(CONFIG_PACKAGE_kmod-b43),m) \
CONFIG_B43LEGACY=$(if $(CONFIG_PACKAGE_kmod-b43legacy),m) \
+ CONFIG_B43_DEBUG=$(if $(CONFIG_PACKAGE_B43_DEBUG),y) \
CONFIG_ATH_COMMON=$(if $(CONFIG_PACKAGE_kmod-ath),m) \
CONFIG_ATH_DEBUG=$(if $(CONFIG_PACKAGE_ATH_DEBUG),y) \
CONFIG_ATH5K_DEBUG=$(if $(CONFIG_PACKAGE_ATH_DEBUG),y) \