summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAndy Boyett <agb@openwrt.org>2009-07-02 07:24:44 +0000
committerAndy Boyett <agb@openwrt.org>2009-07-02 07:24:44 +0000
commit0194fea2857db280b4f3442ba704981fb61d4c5d (patch)
tree186875762c30f4a536dd2dd6ecafff58cfb00202 /package
parent7c68d57ce42996d5f5ebd7e6d2366261ba66e8e5 (diff)
downloadmaster-31e0f0ae-0194fea2857db280b4f3442ba704981fb61d4c5d.tar.gz
master-31e0f0ae-0194fea2857db280b4f3442ba704981fb61d4c5d.tar.bz2
master-31e0f0ae-0194fea2857db280b4f3442ba704981fb61d4c5d.zip
base-files: explicitly create /etc/rc.d/, fixes ImageBuilder when using git instead of svn
SVN-Revision: 16652
Diffstat (limited to 'package')
-rw-r--r--package/base-files/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 69f1e776c2..4d6a15cc95 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=23
+PKG_RELEASE:=24
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
@@ -175,6 +175,7 @@ define Package/base-files$(TARGET)/install
mkdir -p $(1)/CONTROL
mkdir -p $(1)/dev
mkdir -p $(1)/etc/crontabs
+ mkdir -p $(1)/etc/rc.d
mkdir -p $(1)/jffs
mkdir -p $(1)/lib/firmware
$(if $(LIB_SUFFIX),ln -s lib $(1)/lib$(LIB_SUFFIX))