summaryrefslogtreecommitdiffstats
path: root/package/zlib
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-01-02 19:45:50 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-01-02 19:45:50 +0000
commitb1dca51ad02d964e86390e901ba73e711696fb69 (patch)
tree4f74acdd24f301dacea96409d6c8f5feae5816d4 /package/zlib
parentac4b63a18bf6f3a384be304c338b7935b98e62cd (diff)
downloadmaster-31e0f0ae-b1dca51ad02d964e86390e901ba73e711696fb69.tar.gz
master-31e0f0ae-b1dca51ad02d964e86390e901ba73e711696fb69.tar.bz2
master-31e0f0ae-b1dca51ad02d964e86390e901ba73e711696fb69.zip
fix zlib linking failures with gcc-4.4+ (#6173)
SVN-Revision: 19012
Diffstat (limited to 'package/zlib')
-rw-r--r--package/zlib/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/zlib/Makefile b/package/zlib/Makefile
index 19457c1ac8..d8213b972d 100644
--- a/package/zlib/Makefile
+++ b/package/zlib/Makefile
@@ -39,6 +39,7 @@ endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
+ LDSHARED="$(TARGET_CROSS)ld -shared" \
CFLAGS="$(TARGET_CFLAGS) $(FPIC)" \
libz.a libz.so
mkdir -p $(PKG_INSTALL_DIR)