summaryrefslogtreecommitdiffstats
path: root/package/zlib
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-08-01 12:32:53 +0000
committerNicolas Thill <nico@openwrt.org>2007-08-01 12:32:53 +0000
commita596b29f9558d4f9fb5d412150d19ea2e734082b (patch)
tree1b73838f0bd4b91b7fcb0515e213e3e23639f071 /package/zlib
parent37d2c06f8ae38eb71f2f60e3da952975ecc6acbf (diff)
downloadmaster-31e0f0ae-a596b29f9558d4f9fb5d412150d19ea2e734082b.tar.gz
master-31e0f0ae-a596b29f9558d4f9fb5d412150d19ea2e734082b.tar.bz2
master-31e0f0ae-a596b29f9558d4f9fb5d412150d19ea2e734082b.zip
fix openssl with zlib-dynamic (closes: #1182), bump release number
SVN-Revision: 8299
Diffstat (limited to 'package/zlib')
-rw-r--r--package/zlib/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/zlib/Makefile b/package/zlib/Makefile
index 066a399789..15407d5a3f 100644
--- a/package/zlib/Makefile
+++ b/package/zlib/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=zlib
PKG_VERSION:=1.2.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.zlib.net @SF/zlib
@@ -62,8 +62,10 @@ define Build/UninstallDev
$(STAGING_DIR)/usr/lib/libz.{a,so*}
endef
+# libz.so is needed for openssl (zlib-dynamic)
define Package/zlib/install
$(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libz.so $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libz.so.* $(1)/usr/lib/
endef