summaryrefslogtreecommitdiffstats
path: root/package/zlib
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-09-07 10:00:34 +0000
committerMichael Büsch <mb@bu3sch.de>2010-09-07 10:00:34 +0000
commit7b30b70e11b8a7e90eddaa33468118bf1628a3ca (patch)
tree83f13b82bd305caf5d1c3d31f931ae8099eaf603 /package/zlib
parentf54f9b25e1ecc50501e99d0c83843cccbc071f01 (diff)
downloadmaster-31e0f0ae-7b30b70e11b8a7e90eddaa33468118bf1628a3ca.tar.gz
master-31e0f0ae-7b30b70e11b8a7e90eddaa33468118bf1628a3ca.tar.bz2
master-31e0f0ae-7b30b70e11b8a7e90eddaa33468118bf1628a3ca.zip
From: Joseph Roback <openwrt-devel@roback.cc>
26 Makefile patches for enabling parallel builds. Tested on Linux (8-core) and Darwin (12-core), individually and from clean build_root. The first set is from trunk, the second is from feeds/packages. Signed-off-by: Joe Roback <joe@roback.cc> SVN-Revision: 22965
Diffstat (limited to 'package/zlib')
-rw-r--r--package/zlib/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/zlib/Makefile b/package/zlib/Makefile
index c6a18378dc..bcd6ae040a 100644
--- a/package/zlib/Makefile
+++ b/package/zlib/Makefile
@@ -15,6 +15,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.zlib.net @SF/libpng
PKG_MD5SUM:=dee233bf288ee795ac96a98cc2e369b6
+PKG_BUILD_PARALLEL:=1
+
include $(INCLUDE_DIR)/package.mk
define Package/zlib
@@ -37,7 +39,7 @@ define Build/Configure
endef
define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
LDSHARED="$(TARGET_CROSS)ld -shared" \
CFLAGS="$(TARGET_CFLAGS) $(FPIC)" \