summaryrefslogtreecommitdiffstats
path: root/package/wprobe/src/user/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-07-06 19:05:24 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-07-06 19:05:24 +0000
commit5447d6c44b63354b11ceb648e199282dbb65f623 (patch)
tree762b9ea294024b359d37d7cd6b649158666591cc /package/wprobe/src/user/Makefile
parent069dbf6fd412aa01e384c8ca5fd2b51306a51412 (diff)
downloadmaster-31e0f0ae-5447d6c44b63354b11ceb648e199282dbb65f623.tar.gz
master-31e0f0ae-5447d6c44b63354b11ceb648e199282dbb65f623.tar.bz2
master-31e0f0ae-5447d6c44b63354b11ceb648e199282dbb65f623.zip
upgrade to the new version of wprobe - includes reconfigurable layer 2 statistics, remote access, more configuration options and many bugfixes
SVN-Revision: 16719
Diffstat (limited to 'package/wprobe/src/user/Makefile')
-rw-r--r--package/wprobe/src/user/Makefile31
1 files changed, 24 insertions, 7 deletions
diff --git a/package/wprobe/src/user/Makefile b/package/wprobe/src/user/Makefile
index e10dfc0d24..01e83da3eb 100644
--- a/package/wprobe/src/user/Makefile
+++ b/package/wprobe/src/user/Makefile
@@ -1,21 +1,38 @@
-CFLAGS = -O2
-CPPFLAGS ?= -I../kernel
-WFLAGS = -Wall -Werror
+include ../Makefile.inc
+
+CPPFLAGS += -I../kernel
LDFLAGS =
+ifneq ($(HOST_OS),Linux)
+USE_LIBNL_MICRO=1
+else
+USE_LIBNL_MICRO=
+endif
+
+ifeq ($(USE_LIBNL_MICRO),1)
+LIBNL_PREFIX = /usr/local
+LIBNL = $(LIBNL_PREFIX)/lib/libnl-micro.a
+CPPFLAGS += -I$(LIBNL_PREFIX)/include/libnl-micro
+EXTRA_CFLAGS += -DNO_LOCAL_ACCESS
+else
LIBNL = -lnl
+endif
+
LIBM = -lm
LIBS = $(LIBNL) $(LIBM)
-all: libwprobe.a wprobe-info
+all: libwprobe.a wprobe-util
-libwprobe.a: wprobe.o
+libwprobe.a: wprobe-lib.o
rm -f $@
$(AR) rcu $@ $^
$(RANLIB) $@
%.o: %.c
- $(CC) $(WFLAGS) -c -o $@ $(CPPFLAGS) $(CFLAGS) $<
+ $(CC) $(WFLAGS) -c -o $@ $(CPPFLAGS) $(CFLAGS) $(EXTRA_CFLAGS) $<
-wprobe-info: wprobe-info.o wprobe.o
+wprobe-util: wprobe-util.o wprobe-lib.o
$(CC) -o $@ $^ $(LDFLAGS) $(LIBS)
+
+clean:
+ rm -f *.o *.a wprobe-util