summaryrefslogtreecommitdiffstats
path: root/package/wlcompat
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-11-23 00:29:07 +0000
commitc2211dc51e98fa27d565c44179c3044723e69253 (patch)
treed97c293836c481a19206daabf6f6dd18c5a1e2d3 /package/wlcompat
parentd48cc978a7c8c0b6466eec7bf063f78a99e287cb (diff)
downloadmaster-31e0f0ae-c2211dc51e98fa27d565c44179c3044723e69253.tar.gz
master-31e0f0ae-c2211dc51e98fa27d565c44179c3044723e69253.tar.bz2
master-31e0f0ae-c2211dc51e98fa27d565c44179c3044723e69253.zip
replace lots of manual install commands with INSTALL_* variables
SVN-Revision: 5624
Diffstat (limited to 'package/wlcompat')
-rw-r--r--package/wlcompat/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/wlcompat/Makefile b/package/wlcompat/Makefile
index 4a37294658..44acaee1f1 100644
--- a/package/wlcompat/Makefile
+++ b/package/wlcompat/Makefile
@@ -62,14 +62,14 @@ define Build/Compile
endef
define Package/kmod-wlcompat/install
- install -d -m0755 $(1)/lib/modules/$(LINUX_VERSION)
+ $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
$(CP) $(PKG_BUILD_DIR)/wlcompat.o $(1)/lib/modules/$(LINUX_VERSION)/
- install -d -m0755 $(1)/etc/modules.d
+ $(INSTALL_DIR) $(1)/etc/modules.d
echo "wlcompat" > $(1)/etc/modules.d/30-wlcompat
endef
define Package/kmod-wlcompat-debug/install
- install -d -m0755 $(1)/lib/modules/$(LINUX_VERSION)
+ $(INSTALL_DIR) $(1)/lib/modules/$(LINUX_VERSION)
$(CP) $(PKG_BUILD_DIR)/wlcompat-debug.o $(1)/lib/modules/$(LINUX_VERSION)/
endef