summaryrefslogtreecommitdiffstats
path: root/package/vsc73x5-ucode/files
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-02-24 13:38:54 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-02-24 13:38:54 +0000
commit5bc415c2d650dbf21da567415cfc1d8f3477ec72 (patch)
treeb27583f44943ad6190c40c54f95cfed7bc14952a /package/vsc73x5-ucode/files
parentf771c3503379387d4a21ce4e6bc71207724647dc (diff)
downloadmaster-31e0f0ae-5bc415c2d650dbf21da567415cfc1d8f3477ec72.tar.gz
master-31e0f0ae-5bc415c2d650dbf21da567415cfc1d8f3477ec72.tar.bz2
master-31e0f0ae-5bc415c2d650dbf21da567415cfc1d8f3477ec72.zip
package: add VSC73[89]5 microcode for the AP83/PB44 boards
SVN-Revision: 19836
Diffstat (limited to 'package/vsc73x5-ucode/files')
-rw-r--r--package/vsc73x5-ucode/files/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/vsc73x5-ucode/files/Makefile b/package/vsc73x5-ucode/files/Makefile
new file mode 100644
index 0000000000..550f51df79
--- /dev/null
+++ b/package/vsc73x5-ucode/files/Makefile
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+CC:=gcc
+OBJCOPY:=objcopy
+
+all: g5_Plus1_2_31_unmanaged_Atheros_v3.bin \
+ g5_Plus1_2_31_unmanaged_Atheros_v4.bin \
+ g5_Plus1_2_29b_unmanaged_Atheros_v5.bin \
+ g5e_Plus1_2_29a_unmanaged_Atheros_v3.bin
+
+%.o: %.c
+ $(CC) $(CFLAGS) -c $^ -o $@
+
+%.bin: %.o
+ $(OBJCOPY) -O binary -j .data $^ $@