summaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorHans Dedecker <hans.dedecker@technicolor.com>2016-06-08 16:39:04 +0200
committerJo-Philipp Wich <jo@mein.io>2016-06-10 18:05:08 +0200
commit96db69bd45e459def044645ad759245581a6a5b2 (patch)
tree91bbb55025f8b5a4a5f59fc7c8e661cb56d470ab /package/utils
parent7eaacd4d233678132914dc67f25f8b8d51100400 (diff)
downloadmaster-31e0f0ae-96db69bd45e459def044645ad759245581a6a5b2.tar.gz
master-31e0f0ae-96db69bd45e459def044645ad759245581a6a5b2.tar.bz2
master-31e0f0ae-96db69bd45e459def044645ad759245581a6a5b2.zip
busybox: Call ntpd hotplug script for every action
Daemons that are waiting for a timesync are only triggered when the action is stratum. As step is the first sync action pass all actions to the ntpd hotplug scripts; it's up to the ntpd hotplugscript to filter out the actions it is interested in. Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/busybox/Makefile2
-rwxr-xr-xpackage/utils/busybox/files/ntpd-hotplug1
2 files changed, 1 insertions, 2 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 50e2baa031..36d02e2e91 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.24.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/utils/busybox/files/ntpd-hotplug b/package/utils/busybox/files/ntpd-hotplug
index ddc1490a47..8d6d609166 100755
--- a/package/utils/busybox/files/ntpd-hotplug
+++ b/package/utils/busybox/files/ntpd-hotplug
@@ -1,3 +1,2 @@
#!/bin/sh
-[ "$1" = stratum ] || exit 0
ACTION="$1" /sbin/hotplug-call ntp