summaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-30 12:53:02 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-31 12:25:24 +0200
commit9201e88f518dbe5246aa2f77342175805ef10cdd (patch)
tree55efdd6133e02b7cebf89c41eaa84fcfb4206fae /package/utils
parent467dee32ede56993353e3bc64cb00c3e025e9f71 (diff)
downloadmaster-31e0f0ae-9201e88f518dbe5246aa2f77342175805ef10cdd.tar.gz
master-31e0f0ae-9201e88f518dbe5246aa2f77342175805ef10cdd.tar.bz2
master-31e0f0ae-9201e88f518dbe5246aa2f77342175805ef10cdd.zip
kernel: remove hostap driver
It has been marked as broken for well over a month now and nobody has complained. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/hostap-utils/Makefile44
1 files changed, 0 insertions, 44 deletions
diff --git a/package/utils/hostap-utils/Makefile b/package/utils/hostap-utils/Makefile
deleted file mode 100644
index 1d7b22122e..0000000000
--- a/package/utils/hostap-utils/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=hostap-utils
-PKG_VERSION:=0.4.7
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
-PKG_MD5SUM:=afe041581b8f01666e353bec20917c85
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/hostap-utils
- SECTION:=net
- CATEGORY:=Network
- DEPENDS:=kmod-hostap
- TITLE:=Host AP driver utility programs
- URL:=http://hostap.epitest.fi/
-endef
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -Wall" \
- all
-endef
-
-define Package/hostap-utils/install
- $(INSTALL_DIR) $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostap_crypt_conf $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostap_diag $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostap_io_debug $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostap_rid $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/prism2_srec $(1)/usr/sbin/
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/split_combined_hex $(1)/usr/sbin/
-endef
-
-$(eval $(call BuildPackage,hostap-utils))