summaryrefslogtreecommitdiffstats
path: root/package/utils/jsonfilter
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-06-18 10:10:30 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-06-18 10:10:30 +0000
commita5ca7a3dd96f4bfc29057537153ec5a95da3cf79 (patch)
tree7333cf4ee69f82a5e9ca81c9e46ab2dc22e15e25 /package/utils/jsonfilter
parentefcec0faaf7e2977681ccb533d07abfb7f36b771 (diff)
downloadmaster-31e0f0ae-a5ca7a3dd96f4bfc29057537153ec5a95da3cf79.tar.gz
master-31e0f0ae-a5ca7a3dd96f4bfc29057537153ec5a95da3cf79.tar.bz2
master-31e0f0ae-a5ca7a3dd96f4bfc29057537153ec5a95da3cf79.zip
jsonpath: rename to jsonfilter and rewrite from flex/bison to lemon
This commit renames the jsonpath binary to jsonfilter to avoid clashing with a Python extension of the same name. The utility itself has been rewritten to use SQLite3's lemon parser generator instead of a flex/bison combination which results in a much smaller binary. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 41258
Diffstat (limited to 'package/utils/jsonfilter')
-rw-r--r--package/utils/jsonfilter/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/package/utils/jsonfilter/Makefile b/package/utils/jsonfilter/Makefile
new file mode 100644
index 0000000000..1ddb22f3f1
--- /dev/null
+++ b/package/utils/jsonfilter/Makefile
@@ -0,0 +1,32 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=jsonfilter
+PKG_VERSION:=2014-06-18
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=http://git.openwrt.org/project/jsonpath.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=c0e1d4495a8afe51cc1900269d6a6fcf0b51a761
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+CMAKE_INSTALL:=1
+
+PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/jsonfilter
+ SECTION:=base
+ CATEGORY:=Base system
+ DEPENDS:=+libubox +libjson-c
+ TITLE:=OpenWrt JSON filter utility
+ URL:=http://git.openwrt.org/?p=project/jsonpath.git
+endef
+
+define Package/jsonfilter/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/jsonpath $(1)/usr/bin/jsonfilter
+endef
+
+$(eval $(call BuildPackage,jsonfilter))