summaryrefslogtreecommitdiffstats
path: root/package/utils/ct-bugcheck/Makefile
diff options
context:
space:
mode:
authorBen Greear <greearb@candelatech.com>2016-08-24 14:20:58 -0700
committerFelix Fietkau <nbd@nbd.name>2016-08-28 13:51:41 +0200
commit545d86490ca2709d87e6e5ec0658316424b5b739 (patch)
treedb6fd68f487bafd34988b9a2d7743f211ffcc8cf /package/utils/ct-bugcheck/Makefile
parentd66db35a1d363cb6323bf956161ad7106195a361 (diff)
downloadmaster-31e0f0ae-545d86490ca2709d87e6e5ec0658316424b5b739.tar.gz
master-31e0f0ae-545d86490ca2709d87e6e5ec0658316424b5b739.tar.bz2
master-31e0f0ae-545d86490ca2709d87e6e5ec0658316424b5b739.zip
ct-bugcheck: Add tools to poll for and report ath10k firmware crashes.
This tool can periodically check for ath10k firmware crashes. If it finds a crash, it will package up the binary crash dump, some OS level things like dmesg, lspci, etc into a tar file. It then notifies the user about the crash and asks them to report the bug to the appropriate email address. This is most useful when used with ath10k-ct driver and CT ath10k firmware, but it should also report issues with stock ath10k driver and firmware in case one has appropriate contacts to debug them. This tool could be extended later for other modules/bugs/etc. Signed-off-by: Ben Greear <greearb@candelatech.com>
Diffstat (limited to 'package/utils/ct-bugcheck/Makefile')
-rw-r--r--package/utils/ct-bugcheck/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/package/utils/ct-bugcheck/Makefile b/package/utils/ct-bugcheck/Makefile
new file mode 100644
index 0000000000..5deb1e0d35
--- /dev/null
+++ b/package/utils/ct-bugcheck/Makefile
@@ -0,0 +1,52 @@
+#
+# Copyright (C) 2016 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=ct-bugcheck
+PKG_RELEASE:=2016-07-21
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/ct-bugcheck
+ SECTION:=utils
+ CATEGORY:=Utilities
+ TITLE:=Bug checking and reporting utility
+ VERSION:=$(PKG_RELEASE)
+ MAINTAINER:=Ben Greear <greearb@candelatech.com>
+endef
+
+define Package/ct-bugcheck/description
+ Scripts to check for bugs (like firmware crashes) and package them for reporting.
+ Currently this script only checks for ath10k firmware crashes.
+ Once installed, you can enable this tool by creating a file called
+ /etc/config/bugcheck with the following contents:
+ DO_BUGCHECK=1
+ export DO_BUGCHECK
+
+endef
+
+define Build/Prepare
+ $(CP) src/bugcheck.sh $(PKG_BUILD_DIR)/
+ $(CP) src/bugchecker.sh $(PKG_BUILD_DIR)/
+ $(CP) src/bugcheck.initd $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+ true
+endef
+
+define Package/ct-bugcheck/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/bugcheck.sh $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/bugchecker.sh $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/bugcheck.initd $(1)/etc/init.d/bugcheck
+endef
+
+$(eval $(call BuildPackage,ct-bugcheck))