summaryrefslogtreecommitdiffstats
path: root/package/utils/bzip2
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-06-14 17:43:34 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-06-14 17:43:34 +0000
commitb7b855f9ebab26effce3af440d011fbe856df52b (patch)
tree977edc63a388a2403f5abf5a949b72192fa78ee4 /package/utils/bzip2
parent389144d7019a94654cc56e378742f82cd2c511e3 (diff)
downloadmaster-31e0f0ae-b7b855f9ebab26effce3af440d011fbe856df52b.tar.gz
master-31e0f0ae-b7b855f9ebab26effce3af440d011fbe856df52b.tar.bz2
master-31e0f0ae-b7b855f9ebab26effce3af440d011fbe856df52b.zip
bzip2: import package from packages.git
bzip2 is required by elfutils, itself required by perf. So we'll move this package from packages.git and make it part of the core distribution. Signed-off-by: Mathieu Olivari <mathieu@codeaurora.org> SVN-Revision: 45968
Diffstat (limited to 'package/utils/bzip2')
-rw-r--r--package/utils/bzip2/Makefile87
1 files changed, 87 insertions, 0 deletions
diff --git a/package/utils/bzip2/Makefile b/package/utils/bzip2/Makefile
new file mode 100644
index 0000000000..493ccc9317
--- /dev/null
+++ b/package/utils/bzip2/Makefile
@@ -0,0 +1,87 @@
+#
+# Copyright (C) 2007-2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bzip2
+PKG_VERSION:=1.0.6
+PKG_RELEASE:=2
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.bzip.org/$(PKG_VERSION)
+PKG_MD5SUM:=00b516f4704d4a7cb50a1d97e6e8e15b
+PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
+
+PKG_LICENSE:=BZIP2
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/bzip2/Default
+ SUBMENU:=Compression
+ URL:=http://www.bzip.org/
+endef
+
+define Package/libbz2
+$(call Package/bzip2/Default)
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=
+ TITLE:=bzip2 library.
+endef
+
+define Package/libbz2/description
+ bzip2 is a freely available, patent free, high-quality
+ data compressor. This packages provides libbz2 library.
+endef
+
+define Package/bzip2
+$(call Package/bzip2/Default)
+ SECTION:=utils
+ CATEGORY:=Utilities
+ DEPENDS:=+libbz2
+ TITLE:=bzip2 is a compression utility.
+endef
+
+define Package/bzip2/description
+ bzip2 is a freely available, patent free, high-quality
+ data compressor. This package provides the binary.
+endef
+
+TARGET_CFLAGS += \
+ $(FPIC) \
+ $(TARGET_LDFLAGS)
+
+CONFIGURE_ARGS += --prefix=/usr
+
+MAKE_FLAGS += \
+ -f Makefile-libbz2_so \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ all
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_BUILD_DIR)/bzlib.h $(1)/usr/include/
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/libbz2.so.$(PKG_VERSION) $(1)/usr/lib/
+ $(LN) libbz2.so.$(PKG_VERSION) $(1)/usr/lib/libbz2.so.1.0
+ $(LN) libbz2.so.$(PKG_VERSION) $(1)/usr/lib/libbz2.so
+endef
+
+define Package/libbz2/install
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_BUILD_DIR)/libbz2.so.$(PKG_VERSION) $(1)/usr/lib/
+ $(LN) libbz2.so.$(PKG_VERSION) $(1)/usr/lib/libbz2.so.1.0
+endef
+
+define Package/bzip2/install
+ $(INSTALL_DIR) $(1)/usr/bin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/bzip2-shared $(1)/usr/bin/bzip2
+endef
+
+$(eval $(call BuildPackage,libbz2))
+$(eval $(call BuildPackage,bzip2))