summaryrefslogtreecommitdiffstats
path: root/package/utils/busybox/patches/110-no_static_libgcc.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-05-25 17:42:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-05-25 17:42:09 +0000
commitf4f553efa787e1f8f25bb2176f5e6c4c3aa659a9 (patch)
tree310f556f4a68661a07ada2d87790ff02796c941a /package/utils/busybox/patches/110-no_static_libgcc.patch
parenta54791f2baa2e193b5197b754f0b6b29d86d656e (diff)
downloadmaster-31e0f0ae-f4f553efa787e1f8f25bb2176f5e6c4c3aa659a9.tar.gz
master-31e0f0ae-f4f553efa787e1f8f25bb2176f5e6c4c3aa659a9.tar.bz2
master-31e0f0ae-f4f553efa787e1f8f25bb2176f5e6c4c3aa659a9.zip
busybox: update to 1.22.1
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 40852
Diffstat (limited to 'package/utils/busybox/patches/110-no_static_libgcc.patch')
-rw-r--r--package/utils/busybox/patches/110-no_static_libgcc.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/utils/busybox/patches/110-no_static_libgcc.patch b/package/utils/busybox/patches/110-no_static_libgcc.patch
new file mode 100644
index 0000000000..2148a09e00
--- /dev/null
+++ b/package/utils/busybox/patches/110-no_static_libgcc.patch
@@ -0,0 +1,11 @@
+--- a/Makefile.flags
++++ b/Makefile.flags
+@@ -51,7 +51,7 @@ CFLAGS += $(call cc-option,-fno-builtin-
+ # -fno-guess-branch-probability: prohibit pseudo-random guessing
+ # of branch probabilities (hopefully makes bloatcheck more stable):
+ CFLAGS += $(call cc-option,-fno-guess-branch-probability,)
+-CFLAGS += $(call cc-option,-funsigned-char -static-libgcc,)
++CFLAGS += $(call cc-option,-funsigned-char,)
+ CFLAGS += $(call cc-option,-falign-functions=1 -falign-jumps=1 -falign-labels=1 -falign-loops=1,)
+ # Defeat .eh_frame bloat (gcc 4.6.3 x86-32 defconfig: 20% smaller busybox binary):
+ CFLAGS += $(call cc-option,-fno-unwind-tables,)