summaryrefslogtreecommitdiffstats
path: root/package/utils/busybox/Makefile
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2016-05-23 14:30:57 +0200
committerJo-Philipp Wich <jo@mein.io>2016-05-24 13:30:58 +0200
commit6707d9750aa37df75fc1d5c9e64ab599f608c3a2 (patch)
treec28c2c4655b77c5008ba93e358592d680abbb8cb /package/utils/busybox/Makefile
parent2ac21bd793946a214295b760cd652b4150d3dc07 (diff)
downloadmaster-31e0f0ae-6707d9750aa37df75fc1d5c9e64ab599f608c3a2.tar.gz
master-31e0f0ae-6707d9750aa37df75fc1d5c9e64ab599f608c3a2.tar.bz2
master-31e0f0ae-6707d9750aa37df75fc1d5c9e64ab599f608c3a2.zip
busybox: sysntpd - Support for NTP servers received via DHCP(v6)
The busybox ntpd utility currently uses ntp servers specified in uci. This patch allows the ntpd utility to use NTP servers received via DHCP(v6) Following uci parameters have been added: use_dhcp : enables NTP server config via DHCP(v6) dhcp_interface : use NTP servers received only on the specified DHCP(v6) interfaces; if empty all interfaces are considered Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package/utils/busybox/Makefile')
-rw-r--r--package/utils/busybox/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 24c064cf7c..065bf7df6f 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=busybox
PKG_VERSION:=1.24.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_FLAGS:=essential
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -42,7 +42,7 @@ define Package/busybox
MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
TITLE:=Core utilities for embedded Linux
URL:=http://busybox.net/
- DEPENDS:=+BUSYBOX_USE_LIBRPC:librpc +BUSYBOX_CONFIG_PAM:libpam
+ DEPENDS:=+BUSYBOX_USE_LIBRPC:librpc +BUSYBOX_CONFIG_PAM:libpam +BUSYBOX_CONFIG_NTPD:jsonfilter
MENU:=1
endef