summaryrefslogtreecommitdiffstats
path: root/package/utils/busybox/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-12-16 19:09:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-12-16 19:09:57 +0000
commit405b5c2b925d4e6342c364d12264a6a108d13ba7 (patch)
tree0e03014a052e5ada9a2fbf0053afe04f7c6e70fb /package/utils/busybox/Makefile
parentcc304329b3d2eca47330b31a0c810589bdc7a656 (diff)
downloadmaster-31e0f0ae-405b5c2b925d4e6342c364d12264a6a108d13ba7.tar.gz
master-31e0f0ae-405b5c2b925d4e6342c364d12264a6a108d13ba7.tar.bz2
master-31e0f0ae-405b5c2b925d4e6342c364d12264a6a108d13ba7.zip
busybox: remove busybox menuconfig from top level menuconfig
This will help with avoiding bogus bug reports caused by stale configs and bad cases of user tinkering :) Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 39106
Diffstat (limited to 'package/utils/busybox/Makefile')
-rw-r--r--package/utils/busybox/Makefile28
1 files changed, 13 insertions, 15 deletions
diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 15f96ebb3c..db8d0339d8 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -17,7 +17,7 @@ PKG_SOURCE_URL:=http://www.busybox.net/downloads \
http://distfiles.gentoo.org/distfiles/
PKG_MD5SUM:=9c0cae5a0379228e7b55e5b29528df8e
-PKG_BUILD_DEPENDS:=BUSYBOX_CONFIG_FEATURE_HAVE_RPC:librpc
+PKG_CONFIG_DEPENDS:=CONFIG_BUSYBOX_ENABLE_NFS_MOUNT
PKG_BUILD_PARALLEL:=1
PKG_LICENSE:=GPLv2 BSD-4c
@@ -25,10 +25,6 @@ PKG_LICENSE_FILES:=LICENSE archival/libarchive/bz/LICENSE
include $(INCLUDE_DIR)/package.mk
-ifeq ($(DUMP),)
- STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell $(SH_FUNC) grep '^CONFIG_BUSYBOX_' $(TOPDIR)/.config | md5s)
-endif
-
ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
BB_MAKE_VERBOSE := V=1
else
@@ -46,7 +42,7 @@ define Package/busybox
MAINTAINER:=Nicolas Thill <nico@openwrt.org>
TITLE:=Core utilities for embedded Linux
URL:=http://busybox.net/
- DEPENDS:=+BUSYBOX_CONFIG_FEATURE_HAVE_RPC:librpc
+ DEPENDS:=+BUSYBOX_ENABLE_NFS_MOUNT:librpc
MENU:=1
endef
@@ -59,9 +55,18 @@ define Package/busybox/config
source "$(SOURCE)/Config.in"
endef
+CONFIG_TEMPLATE:=./config/default
+
+LDLIBS:=m crypt
+ifdef CONFIG_BUSYBOX_ENABLE_NFS_MOUNT
+ TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
+ export LDFLAGS=$(TARGET_LDFLAGS)
+ LDLIBS += rpc
+ CONFIG_TEMPLATE:=+ $(CONFIG_TEMPLATE) ./config/nfsmount
+endif
+
define Build/Configure
- rm -f $(PKG_BUILD_DIR)/.configured*
- grep 'CONFIG_BUSYBOX_' $(TOPDIR)/.config | sed -e "s,\\(# \)\\?CONFIG_BUSYBOX_\\(.*\\),\\1\\2,g" > $(PKG_BUILD_DIR)/.config
+ $(SCRIPT_DIR)/kconfig.pl $(CONFIG_TEMPLATE) > $(PKG_BUILD_DIR)/.config
yes 'n' | $(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
@@ -75,13 +80,6 @@ ifdef CONFIG_GCC_VERSION_LLVM
TARGET_CFLAGS += -fnested-functions
endif
-LDLIBS:=m crypt
-ifdef CONFIG_BUSYBOX_CONFIG_FEATURE_HAVE_RPC
- TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
- export LDFLAGS=$(TARGET_LDFLAGS)
- LDLIBS += rpc
-endif
-
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \