summaryrefslogtreecommitdiffstats
path: root/package/uhttpd
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2011-11-07 22:59:06 +0000
committerNicolas Thill <nico@openwrt.org>2011-11-07 22:59:06 +0000
commit75e186832a099b0844c697738e1174a7d882c9f6 (patch)
tree33eeeeb3e7c83cb05de87e1ca57697c9ded0714d /package/uhttpd
parentd7409c85b50cc51c88607f8f9fd362fd7d55b0bb (diff)
downloadmaster-31e0f0ae-75e186832a099b0844c697738e1174a7d882c9f6.tar.gz
master-31e0f0ae-75e186832a099b0844c697738e1174a7d882c9f6.tar.bz2
master-31e0f0ae-75e186832a099b0844c697738e1174a7d882c9f6.zip
package/uhttpd: use new service wrapper
SVN-Revision: 28841
Diffstat (limited to 'package/uhttpd')
-rw-r--r--package/uhttpd/Makefile2
-rwxr-xr-xpackage/uhttpd/files/uhttpd.init18
2 files changed, 9 insertions, 11 deletions
diff --git a/package/uhttpd/Makefile b/package/uhttpd/Makefile
index 6285eab9ac..d8bd33c075 100644
--- a/package/uhttpd/Makefile
+++ b/package/uhttpd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_RELEASE:=28
+PKG_RELEASE:=29
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
PKG_CONFIG_DEPENDS := \
diff --git a/package/uhttpd/files/uhttpd.init b/package/uhttpd/files/uhttpd.init
index 1ec009663b..c370f90109 100755
--- a/package/uhttpd/files/uhttpd.init
+++ b/package/uhttpd/files/uhttpd.init
@@ -2,10 +2,13 @@
# Copyright (C) 2010 Jo-Philipp Wich
START=50
+
+SERVICE_DAEMONIZE=1
+SERVICE_WRITE_PID=1
+
UHTTPD_BIN="/usr/sbin/uhttpd"
PX5G_BIN="/usr/sbin/px5g"
-
append_arg() {
local cfg="$1"
local var="$2"
@@ -103,21 +106,16 @@ start_instance()
}
}
- start-stop-daemon -S -x $UHTTPD_BIN \
- -p /var/run/uhttpd_${cfg}.pid \
- -m -b -- -f $UHTTPD_ARGS
+ SERVICE_PID_FILE=/var/run/uhttpd_${cfg}.pid
+ service_start $UHTTPD_BIN -f $UHTTPD_ARGS
}
stop_instance()
{
local cfg="$1"
- [ -f /var/run/uhttpd_${cfg}.pid ] && {
- start-stop-daemon -K -q -n ${UHTTPD_BIN##*/} \
- -p /var/run/uhttpd_${cfg}.pid -s TERM
-
- rm -f /var/run/uhttpd_${cfg}.pid
- }
+ SERVICE_PID_FILE=/var/run/uhttpd_${cfg}.pid
+ service_stop $UHTTPD_BIN
}
start() {