summaryrefslogtreecommitdiffstats
path: root/package/uhttpd
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-03-27 01:47:36 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-03-27 01:47:36 +0000
commit161325ac4fffd1c54b0dc267b2352f765dfbd52d (patch)
tree984011d6cc209df3aa992f4797252159c546ebfe /package/uhttpd
parent8c9b818a24045c15f40fc415cd1dde78c438555a (diff)
downloadmaster-31e0f0ae-161325ac4fffd1c54b0dc267b2352f765dfbd52d.tar.gz
master-31e0f0ae-161325ac4fffd1c54b0dc267b2352f765dfbd52d.tar.bz2
master-31e0f0ae-161325ac4fffd1c54b0dc267b2352f765dfbd52d.zip
uhttpd: clear script timeout as soon as data is received from the child
SVN-Revision: 20501
Diffstat (limited to 'package/uhttpd')
-rw-r--r--package/uhttpd/Makefile2
-rw-r--r--package/uhttpd/src/uhttpd-cgi.c12
-rw-r--r--package/uhttpd/src/uhttpd-lua.c12
3 files changed, 15 insertions, 11 deletions
diff --git a/package/uhttpd/Makefile b/package/uhttpd/Makefile
index 3e7344911b..d5c4aa6252 100644
--- a/package/uhttpd/Makefile
+++ b/package/uhttpd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=uhttpd
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
diff --git a/package/uhttpd/src/uhttpd-cgi.c b/package/uhttpd/src/uhttpd-cgi.c
index 4a30f2fc9a..8bd22503de 100644
--- a/package/uhttpd/src/uhttpd-cgi.c
+++ b/package/uhttpd/src/uhttpd-cgi.c
@@ -360,6 +360,9 @@ void uh_cgi_request(struct client *cl, struct http_request *req, struct path_inf
memset(hdr, 0, sizeof(hdr));
+ timeout.tv_sec = cl->server->conf->script_timeout;
+ timeout.tv_usec = 0;
+
#define ensure(x) \
do { if( x < 0 ) goto out; } while(0)
@@ -372,12 +375,11 @@ void uh_cgi_request(struct client *cl, struct http_request *req, struct path_inf
FD_SET(rfd[0], &reader);
FD_SET(wfd[1], &writer);
- timeout.tv_sec = cl->server->conf->script_timeout;
- timeout.tv_usec = 0;
-
/* wait until we can read or write or both */
- if( select(fd_max, &reader, (content_length > -1) ? &writer : NULL, NULL, &timeout) > 0 )
- {
+ if( select(fd_max, &reader,
+ (content_length > -1) ? &writer : NULL, NULL,
+ (header_sent < 1) ? &timeout : NULL) > 0
+ ) {
/* ready to write to cgi program */
if( FD_ISSET(wfd[1], &writer) )
{
diff --git a/package/uhttpd/src/uhttpd-lua.c b/package/uhttpd/src/uhttpd-lua.c
index c1e7490438..fcbdc64825 100644
--- a/package/uhttpd/src/uhttpd-lua.c
+++ b/package/uhttpd/src/uhttpd-lua.c
@@ -439,6 +439,9 @@ void uh_lua_request(struct client *cl, struct http_request *req, lua_State *L)
data_sent = 0;
+ timeout.tv_sec = cl->server->conf->script_timeout;
+ timeout.tv_usec = 0;
+
/* I/O loop, watch our pipe ends and dispatch child reads/writes from/to socket */
while( 1 )
{
@@ -448,12 +451,11 @@ void uh_lua_request(struct client *cl, struct http_request *req, lua_State *L)
FD_SET(rfd[0], &reader);
FD_SET(wfd[1], &writer);
- timeout.tv_sec = cl->server->conf->script_timeout;
- timeout.tv_usec = 0;
-
/* wait until we can read or write or both */
- if( select(fd_max, &reader, (content_length > -1) ? &writer : NULL, NULL, &timeout) > 0 )
- {
+ if( select(fd_max, &reader,
+ (content_length > -1) ? &writer : NULL, NULL,
+ (data_sent < 1) ? &timeout : NULL) > 0
+ ) {
/* ready to write to Lua child */
if( FD_ISSET(wfd[1], &writer) )
{