summaryrefslogtreecommitdiffstats
path: root/package/uhttpd/src/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-05-28 00:52:24 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-05-28 00:52:24 +0000
commit022fa36b40b02248436584cf0f71bb26d79eb644 (patch)
tree8cb1f4d8f1ab4f1aee4538621684a188101c867c /package/uhttpd/src/Makefile
parent8039a1bbb2056019458b5179108e399d0fcb0622 (diff)
downloadmaster-31e0f0ae-022fa36b40b02248436584cf0f71bb26d79eb644.tar.gz
master-31e0f0ae-022fa36b40b02248436584cf0f71bb26d79eb644.tar.bz2
master-31e0f0ae-022fa36b40b02248436584cf0f71bb26d79eb644.zip
uhttpd: - rewrite large parts of the server, use uloop event driven structure - support concurrent requests and make the upper limit configurable - implement initial version of HTTP-to-ubus JSON proxy and session.* namespace - add compile time support for debug information - code style changes - bump package revision
SVN-Revision: 31931
Diffstat (limited to 'package/uhttpd/src/Makefile')
-rw-r--r--package/uhttpd/src/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/package/uhttpd/src/Makefile b/package/uhttpd/src/Makefile
index 2b08ec668c..98226ed206 100644
--- a/package/uhttpd/src/Makefile
+++ b/package/uhttpd/src/Makefile
@@ -41,6 +41,10 @@ ifeq ($(LUA_SUPPORT),1)
CFLAGS += -DHAVE_LUA
endif
+ifeq ($(UBUS_SUPPORT),1)
+ CFLAGS += -DHAVE_UBUS
+endif
+
world: compile
@@ -66,10 +70,19 @@ ifeq ($(TLS_SUPPORT),1)
-o $(TLSLIB) uhttpd-tls.c
endif
+ifeq ($(UBUS_SUPPORT),1)
+ UBUSLIB := uhttpd_ubus.so
+
+ $(UBUSLIB): uhttpd-ubus.c
+ $(CC) $(CFLAGS) $(LDFLAGS) $(FPIC) \
+ -shared -lubus -ljson -lblobmsg_json \
+ -o $(UBUSLIB) uhttpd-ubus.c
+endif
+
%.o: %.c
$(CC) $(CFLAGS) -c -o $@ $<
-compile: $(OBJ) $(TLSLIB) $(LUALIB)
+compile: $(OBJ) $(TLSLIB) $(LUALIB) $(UBUSLIB)
$(CC) -o uhttpd $(LDFLAGS) $(OBJ) $(LIB)
clean: