summaryrefslogtreecommitdiffstats
path: root/package/uboot-lantiq/patches/100-ifx_targets.patch
diff options
context:
space:
mode:
authorRalph Hempel <ralph.hempel@lantiq.com>2010-03-30 13:56:30 +0000
committerRalph Hempel <ralph.hempel@lantiq.com>2010-03-30 13:56:30 +0000
commit046d73d3c2bc3a515024c2cc8339d1177e749b77 (patch)
treee6c0308590b8a125833f31549758973328c4f577 /package/uboot-lantiq/patches/100-ifx_targets.patch
parentaa323e0134c4dd374869446738b701f82d014c89 (diff)
downloadmaster-31e0f0ae-046d73d3c2bc3a515024c2cc8339d1177e749b77.tar.gz
master-31e0f0ae-046d73d3c2bc3a515024c2cc8339d1177e749b77.tar.bz2
master-31e0f0ae-046d73d3c2bc3a515024c2cc8339d1177e749b77.zip
add preliminary AR9 support attention: if caches enabled the network is broken attention: the network of the flash image doesn't work because of enabled caches
SVN-Revision: 20606
Diffstat (limited to 'package/uboot-lantiq/patches/100-ifx_targets.patch')
-rw-r--r--package/uboot-lantiq/patches/100-ifx_targets.patch26
1 files changed, 23 insertions, 3 deletions
diff --git a/package/uboot-lantiq/patches/100-ifx_targets.patch b/package/uboot-lantiq/patches/100-ifx_targets.patch
index 9c313e0a41..da4cd4864c 100644
--- a/package/uboot-lantiq/patches/100-ifx_targets.patch
+++ b/package/uboot-lantiq/patches/100-ifx_targets.patch
@@ -23,7 +23,7 @@
${LIST_au1xx0} \
--- a/Makefile
+++ b/Makefile
-@@ -474,7 +475,7 @@ $(obj)include/autoconf.mk: $(obj)include
+@@ -474,7 +474,7 @@ $(obj)include/autoconf.mk: $(obj)include
set -e ; \
: Extract the config macros ; \
$(CPP) $(CFLAGS) -DDO_DEPS_ONLY -dM include/common.h | \
@@ -32,7 +32,7 @@
mv $@.tmp $@
#########################################################################
-@@ -3354,7 +3355,7 @@ incaip_config: unconfig
+@@ -3354,7 +3354,7 @@ incaip_config: unconfig
{ echo "#define CPU_CLOCK_RATE 150000000" >>$(obj)include/config.h ; \
$(XECHO) "... with 150MHz system clock" ; \
}
@@ -41,7 +41,7 @@
tb0229_config: unconfig
@$(MKCONFIG) $(@:_config=) mips mips tb0229
-@@ -3395,6 +3396,30 @@ vct_platinumavc_onenand_small_config: un
+@@ -3395,6 +3395,50 @@ vct_platinumavc_onenand_small_config: un
@$(MKCONFIG) -a vct mips mips vct micronas
#########################################################################
@@ -68,6 +68,26 @@
+ fi
+ @$(MKCONFIG) -a $(word 1,$(subst _, ,$@)) mips mips easy50712 infineon danube
+
++easy50812%config : unconfig
++ @mkdir -p $(obj)include
++ @mkdir -p $(obj)board/infineon/easy50812
++ @[ -z "$(findstring ramboot,$@)" ] || \
++ { echo "TEXT_BASE = 0xA0400000" >$(obj)board/infineon/easy50812/config.tmp ; \
++ echo "#define CONFIG_SYS_RAMBOOT" >>$(obj)include/config.h ; \
++ $(XECHO) "... with ramboot configuration" ; \
++ }
++ @if [ "$(findstring _DDR,$@)" ] ; then \
++ echo "#define CONFIG_USE_DDR_RAM" >>$(obj)include/config.h ; \
++ DDR=$(subst DDR,,$(filter DDR%,$(subst _, ,$@))); \
++ case "$${DDR}" in \
++ 111M|166M|e111M|e166M|promos400|samsung166|psc166) \
++ $(XECHO) "... with DDR RAM config $${DDR}" ; \
++ echo "#define CONFIG_USE_DDR_RAM_CFG_$${DDR}" >>$(obj)include/config.h ;; \
++ *) $(XECHO) "... DDR RAM config \\\"$${DDR}\\\" unknown, use default"; \
++ esac; \
++ fi
++ @$(MKCONFIG) -a $(word 1,$(subst _, ,$@)) mips mips easy50812 infineon ar9
++
+#########################################################################
## MIPS32 AU1X00
#########################################################################